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About This Guide

This guide provides a step-by-step introduction to the Micro Focus Screen Designer.
The guide shows you how to:

* Create a history file
* Use the Screen Designer to customize a set of screens
* Use the customized screens in Plus mode.

A comprehensive How To section provides further information about customizing screens.

y Note: You can only customize screens for 3270 mainframe and 5250 AS/400 (iSeries) sessions.

Who should read this guide

This guide is intended to be read by all those interested in customizing green screen applications to create
applications with a modern look and feel.

It is expected that readers would mostly be system administrators or other IT personnel with a similar level
of expertise.

Prerequisites

» Micro Focus Reflection Desktop 16.2
* Micro Focus Reflection Desktop Plus Add-On

Accompanying files
The package file containing this guide also contains the following files:

« MF_logo.png

« pie_chart._png

« WebFrame URL.txt
« welcome.png

If you do not have these files, you will not be able to complete some of the exercises in this guide.

Additional resources

In addition to this guide, a series of training videos is available on the Micro Focus Support & Training
YouTube channel:

https://www.youtube.com/playlist?list=PLIUdEXI83_XpQiv45UJauz1FOE23JaULl

Conventions used in this guide

The following typographic conventions are used in this guide:
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This typeface ...

Is used for ...

Bold

Monospace

Windows user interface elements such as window titles, fields, and buttons.
Also used for keyboard keys.
Host user interface elements such as screen titles and labels.

Also used for file names as well as for text that you are asked to type.

Entering commands:

This instructon ...

Means this...

Enter TSOA

Type the TSOA command, then press the Enter key.
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Introduction

You use the Screen Designer to provide a modern look and feel to green screen applications and make
them easier to use. You do this without touching any application code.

When you have customized a set of screens in the Screen Designer, you create a file which you then link
to a host session. When you run the host session in Plus mode, you see modernized screens instead of
standard green screens.

This guide provides instructions for you to start using the Screen Designer to customize green screens.

Note: For the purposes of this guide, only 3270 mainframe screens are used. However, you can also
use the same principles to customize 5250 AS/400 (iSeries) screens.

Terminology

Screen Designer

The customization engine for Plus. It consists of two parts:
Screen Design view

Used to add static controls on specific screens.
Rule Manager window
Used to add dynamic or conditional controls on multiple screens.

Control
A modern visual element that interacts with a green screen. For example, a button.

Rule
A mechanism that automatically creates one or more conditional controls on one or several
screens, managed by rules.

Plus
The middleware used to run green screen applications with a modern interface using
projects created in the Screen Designer.

Plus archive

A collection of files and settings that define screen customizations created in the Screen
Designer and used in a Plus host session.

How it works

The figure below provides an overview of what you do to create and use customized screens:
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* Open a session and connect

Prepare

* Record the screens you want to customize

+ Open the Screen Designer, create a new project, then import the screen history
* Add static controls to the screens in the Screen Designer view
D es | g n * For dynamic or conditional controls, create rules in the Rule Manager window

+ Generate a Plus archive
* Activate Plus mode

= In the session, associate the Plus archive with the session

Architecture

reFLection desktop '—“'-

screen
designer
History

What's new in this version

Fumiba+ Mobie

Grgen SCreen
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Using the Screen Designer

This section provides a step-by-step guide to creating a customization project. You add a number of
controls to various green screens to create a project, then see the results of the customization in Plus
mode.

Getting started

Before you start using the Screen Designer, you need to:

« Extract the files that came with this guide.
e Connect to the Demo Host.

Extracting the package files

Extract the following files from the package . ZIP file to your local machine:

e MF_Logo.png

e« pie_chart.png

« WebFrame URL.txt
« welcome.png

Make a note of where you save the files because you will need them later.

Connecting to the Demo Host

1. From the Windows Start menu, select: Start > All Programs > Micro Focus Reflection > Reflection
Workspace

Reflection starts, showing the Create New Document window:
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2.

3.

Create Mew Document w

D" -q-'im v

Busitt-in templates
3270%erminal SXE0 terminal 3270 printer 5250 primtesr
WT tarminal Web
User defined

Compatibility:
\Refledtion Desitop ~ ® | Creste |

— — - = = d

k.,

Select 3270 Terminal and click Create.

The Create New 3270 Terminal Document window appears:

Create Mew 3270 Terminal Document

E{ ‘3270 Terminal Document Settings

Host name / IP address: Port:

I - 3

Device name:

o Lise Telnet Extended

Terminal

Terminal / Device type:

IBMA-3ITE -G -

Madel 10 Rows: Columns:

[Madel 2 24s80 Extended = | s

[Z] Emabte graphics

Host code page:
| s English £37) x]

Kepowdmap -
C\Program Files (BSIMI...ard Mapsidetault 3270.0kb | Browse..

|7 Contigure goditional settings [ QK I  Cancel I

.

In the Host name / IP address field, type: demo:plus3270.sim
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4. Click OK.
The Create New Document window closes and the host session starts automatically:

| & Fd S Reflection Workspace - furbiied.nd3] = e

| o o Do -

| .
i:C' ¥ untithedd

| Conmecied o e b [demo e 12 sim] HUM anzhm [0

5. Click File > Save As.

The Save As window appears.
6. In the File name field, type Demo Host, then click Save.

Creating a history file

Before you start customizing screens, you need to capture a set of screens in a history file. This section
describes how to record a sequence of screens to use in the Screen Designer.

Recording history
To create a history file:

1. Select Session tab > Screen History.

The History pane appeatrs.
2. Select Session tab > Screen History group > Screen History.

The Screen History pane appears:
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o ¥ d S e Reflection Wirkspace - [Dema Heat ifis] | |
] Quick s~ WY Fasie - g ASoeen + |

| & ®iDema Host

| Connecied s e host [emopius 17 5| HuM gszam | F1 B

3. Atthe ENTER SYSTEM ID : prompt, enter:
TSOA

The screens start to be recorded.
4. Atthe ENTER LOGON 1D: prompt, press Enter.
5. Atthe LAST SYSTEM ACCESS prompt, press Enter.

The READY prompt appears.
6. Click the Manual Capture icon on the History pane toolbar.

This shows how you can capture individual screens. There are two reasons you might want to capture a
screen manually:

* You switched off screen history but need to capture a screen.

* You modified one or more unprotected fields on a screen and want to capture the screen with the
modifications.

7. Enter:

TOYS
8. Atthe TOPCO TOYS, INC screen, press Enter.
9. Enter O.
10.At the CUSTOMER SCREEN, press PF8.
11.At the DETAIL LINE ENTRY SCREEN, press Enter.
12.At the READY prompt, enter:

E
13.At the TOP OF DATA screen, press Enter.
14.At the READY prompt, enter:

R
15.At the TOPCO TOYS, INC screen, press PF3.
16.At the READY prompt, enter:
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A
17.At the EXTENDED ATTRIBUTE TEST screen, press PF3.
18.At the READY prompt, enter:

C

The EUROPEAN CUSTOMER LIST screen appears.
19.Press PF1.

Each screen has been added, in sequence, to the History pane:

—

| & ¥ o S e Refleciien Workspace - [Dema Hest.id3a] : |
[ ooeue B
[IFTP Che B B Aecen Typng - !:'f &) Each
El Gicktiegs = W Fuste - = W Check Seteen » } sl Dot

| 8 ®iDemo Host rdx SomeenHistary

Connecied i e how [demo g 12T sim| UM wers w0

Saving the history to a file
To save the recorded history to a file:

1. Select Appearance group > Plus tab > Plus > Export History for Screen Designer.

The Save As dialog box appears.
2. In the File name field, type DemoHistory.
3. Click Save.

You now have a number of screens to use in your customization project.
4. Select Session tab > Screen History.

The History pane closes.
5. Select Session tab > Host group > Disconnect.

Opening the Screen Designer

To open the Screen Designer, select Appearance tab > Plus group > Plus > Screen Designer.

The Screen Designer window appears:

14 | Using the Screen Designer



S ey

——— -
P9 Mo Pocve Soneen Dnignes Lo i

. ! 1,
|
. a’
i
< &)
. i - i
|
i &)
|
:
.
A ! Screen Designer menu bar and toolbar.
(o History pane. Contains thumbnails of all the screens recorded in the imported history file,
g . .
X together with a search box to search and filter screens.
3 Work area. Contains a full size version of the selected thumbnail. Shows the controls
e associated with the screen.
/ , Control panel. Contains a list of available controls that can be applied to the screen in the
a work area.
ﬁ“} Property grid. Contains a list of available properties for the selected control.
‘.)E_‘? Property description. Provides a description of the selected property in the property grid.
(-‘3 Status bar. Displays the coordinates of the cursor. Useful when looking for coordinates of
49 fields.

Starting a new project

1. Select File > New Project

The New Project dialog appears.
2. In the Name field, type a name for your project, such as DemoHost, then click OK.

Importing history

1. Select File > Import History.

The History Import dialog box appears.
2. Choose your history file, then click Open.
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Thumbnails of the recorded screens appear in the history pane. Each screen has a unique screen ID.
You can also create screen identifications instead of, or in addition to this default ID (see Identify
screens).

The first screen is selected by default and a larger version of it appears in the work area:

B Cumchias: - Wra Facas Sormen Desgasr < i

e 1B 4347112

3. Select File > Save Project.

i Note: It is always good practice to save your project after you have made any changes to it.

Selecting a theme

A theme defines the layout of the screen and the look of each control across all screens in a customization
project.

It is best to choose a theme early in the customization project.

To select a theme:

1. Select Tools > Project Settings

The Project Settings dialog box appears.

Click Themes in the left pane.

Click Change in the right pane. The Choose Theme dialog box appears.
In the left pane, select the Plus Windows Theme thumbnail.

Click OK.

Click OK in the Project Settings dialog box.

2

The theme is applied to all the screens in your project.

For more information about themes, see Using themes.

Adding controls

You will now use the Screen Design view to add controls to your screens.
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You use the Screen Design view to add static controls to specific screens. To add dynamic controls,
controls that repeat on multiple screens or many times on a single screen, you use the Rule Manager. For
information about the Rule Manager, see Using the Rule Manager.

As you go through this section, you add controls to your captured screens progressively. We recommend
that you add the controls in the order they are described to build a completed project.

Note: It is important to remember that, while the Screen Designer is a very powerful tool, it is not
WYSIWYG. You should always adopt an approach of design and test to ensure that what you do in
the Screen Designer has the desired appearance in Plus mode.

Adding a Button control

Button triggers an action or a sequence of actions when clicked.

f Note: In this section you use the MF_Logo . png file supplied with the package file.

1. Ensure the first thumbnail is selected.

2. Drag the Button control icon from the control panel on to the work area and drop it to the left of the
AVAILABLE SYSTEM IDS ARE row.

f Note: When you drop the control on the screen, the property grid is populated.

3. In the property grid, click in the Caption field and delete the text Button.
4. Type Micro Focus SupportLine.

When you click elsewhere on the screen, the text changes on the control.

5. To make the text appear on two lines, click in the Caption field and place your cursor after Micro
Focus, then press Alt+Enter. This splits the line.

6. Use the control's handles to size the control to fit the text.

7. Click in the Tooltip field and type SupportLine Web Site.

4 Comanon
Nami Buttonl
Mo Tant -
Wticra Focus
Tupporiline

4 Actions
Actiong
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8. Click the accelerator button [ next to the Actions field.

The Actions dialog box appears.
9. Under Select type, select WebSite from the drop-down list.
10.Click Add.

A new action appears in the Actions frame and its properties appear in the Properties frame.
11.In the Properties frame, type http://www._microfocus.com/supportline in the

WebSiteAddress field:
WebSite * | Add WebSite |
WiebSite : 4 Action
‘WiebSitedddress microfocus comyisuppartine
A

WebSiteAddress

Runs the user's default browser bo navigate to s specified

Web site,

QK Cancel
12.Click OK.

13.Use the handles on the control to size it for the text.

Your screen should look like this:

P Cwvctior - o Facas Soer. Cesgss

Cnn e way achon ass sescitnd aquaminly
o P o the botion m the amcciey

14.You can also use an image for the button instead of text. To do this, select Image from the Mode list.
15.Click the accelerator button next to ImagePath.

The Choose Image dialog box appears.

16.Click I*/ next to Add to pool.
17.Navigate to where you saved the MF_Logo . png file, select the file, then click Open
18.Ensure the image is selected in the Choose Image dialog box and click OK.

The image appears on the button.
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19.Use the handles on the button to resize the button to 6x1.

Your screen should look like this:

Note: You can also provide a link to an image that is not on your machine. To do this, type the Web
address of the image in the ImagePath field.
20.Select File > Save Project.

Adding a Chooser control

Chooser appears on the screen like a drop-down list. Chooser is used to insert data into a field on the

screen by selecting an item from the list.

1. Drag the Chooser control icon from the control panel on to the work area and drop it on top of TSOA on
the ENTER SYSTEM ID: row:

2. In the property grid, click the accelerator button (] next to Chooserltems.

The Chooserltems dialog box appears:
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= Chooser Toems

Chooses [lems: Properties:

e

Cancel

3. Click the Add button %,
4. In the Properties frame, type Select Host in the Caption field.
5. In the Tooltip field, type Select host system.

This text will appear as you hover over the selection. Tooltip text can be used for tips and helpful
information on the selection.

Leave the ValueTolnsert field empty.

Click the Add button [#/.

In the Properties frame, type WYLBUR in the Caption field.
In the Tooltip field, type Select WYLBUR.

10.In the ValueTolnsert field, type WYL.

© © N o

This is the text that will be placed in the entry field and must match the commands you would normally
manually type in the field.

The Chooserltems dialog box looks like this:

Choaser fems: Properties

O Item - Select Host
1 ltem - WYLBLR

i

Caption WHYLBLIR

Toaltip Select WYLBUR

WalueTolnsert Wl

“ (%% %

VahseTalnsert

| Specdies the bext t2 be inserted when selecting an iem
from the list.

O || Cancel

11.Repeat the above steps to add the following Chooser items:

Caption Tooltip Value To Insert
TSO MVS/XA Select TSO MVS/XA TSOA

TSO MVS/XB Select TSO MVS/XB TSOQ
VM/370 Select VM/370 WM

When complete, the Chooser dialog box looks like this:
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WalueTolnsert
Specifies the text 12 be inFerted when salecling an item
from the list

Ok Cancel

12.When you have finished, click OK.
13.Use the handles on the control to size it so that the text shows correctly.

Your screen should look like this:

P Curcilar: - W Facat Scrmen Dusguar

14.1n the property grid, click the accelerator button [+ next to TextInsertionLocation.

The Select Screen Location window appeatrs.
15.Select Location from the Select By list at the bottom of the window.
16.Click on the T of TSOA to the right of ENTER SYSTEM 1ID: at the location 12,29.
17.Click OK.
18.1n the property grid, click the accelerator button (-] next to Actions.

The Actions dialog box appears.

19.From the Select type list, select EmulationCommand.

20.Click Add.

21.From the Action list, select Enter.
This action sends an Enter command to the host after the Chooser sends the selected text to the
screen location specified by TextinsertionLocation.

22.Click OK.

23.Select File > Save Project.
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Adding a Tooltip control
Tooltip displays text when the mouse hovers over the screen area that Tooltip occupies.

1. Drag the Tooltip control icon from the control panel on to the work area and drop it on top of ENTER
SYSTEM 1ID:

2. Drag the handles on the control so the control covers the screen text:

3. In the property grid, type the following in the Caption field:

Click drop-down list to select system
4. Click in the Caption field and position your cursor just before to.
5. Press Alt+Enter.

The line splits into two.
6. Select File > Save Project.

Adding an AutoExecution control

After you log into theDemo Host, you need to press Enter twice before the READY prompt appears. You
can use an AutoExecution control to automate this sequence. To do this:

1. Inthe left pane, select the second screen.

A larger version of the screen appears in the work area.
2. Drag the AutoExecution control from the control panel and drop it to the right of the Plus icon:
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3.
4.

© © N o v

ACF2, ENTER LOGIN TD

“ Comran

* Aetiora

In the property grid, click the accelerator button (] next to the Actions field.
From the Select type list, select Emulation Command.

-

Select type: Properties:

ErmulationCammand * | Add

oK Cancel

Click Add.

From the Action list, select Enter:

Click OK.

Select the third screen in the left pane:

Add another AutoExecution control and give it the same properties:
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™ ver. Dusg i

1406 -0F P20 FROM WEA

10.Select File > Save Project.

Adding an Image control

Image masks an area of a screen with either a color or an image.

i Note: In this section you use the welcome . png file supplied with the package file.

1. In the history pane, scroll down and select the fourth thumbnail. This shows the READY prompt.

A larger version of the screen appears in the work area:

W

2. Drag the Image control icon from the control panel onto the work area, then use the handles of the
control to size it to 15x66:
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3. In the property grid, select Image from the Type drop-down list.
The ImagePath field appears.
4. Click the accelerator button [ next to the ImagePath field.
The Choose Image dialog box appears.
5. Click [*/ next to Add to pool.
6. Navigate to where you saved the welcome. jpg file, select the file, then click Open.
7. Ensure the image is selected in the Choose Image dialog box and click OK.

The selected image now fills the control on the screen:

i

Note: You can also provide a link to an image that is not on your machine. To do this, type the Web
address of the image in the ImagePath field.

8. Select File > Save Project.
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Adding a MessageBox control

The MessageBox control is an alert message box that can be configured with a title, icon, one to three
buttons, and a message.

1. On the READY screen, drag a MessageBox icon from the property grid on to the work area and drop it
on top of the image you have just created:

. In the property grid, type Warning in the Title.

3. Inthe Text field, type This system is restricted. Click OK to continue or Cancel to
log off.

4. In the Button section with Caption of Cancel, click the accelerator button next to Actions:

N

4 Button

IsVisible o
Caption Cancel
Actions [Collection)

The Actions dialog box appears:
From the Select Type list, select SetText, then click Add.
. In the Properties frame, type 1ogoff in the Text field.

Click the accelerator button next to the TextlnsertionLocation field. The Select Screen Location
window appears.

8. Select Location from the Select By list.
9. Click once under the R of READY. This should be row 2, column 2.
10.Click OK.

The Actions dialog box should look like this:

N oo o
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[ 2ctions " [ 2 i
Select types Properties:
| Sei Tt e Seilext
SetTe + # Actian |
Text logoff
- g
% |
TexilnsertionLocation
Screen hocation.
K | Cancel |

11.From the Select Type list, select EmulationCommand, then click Add.
12.In the Properties frame, select Enter from the EmulationCommand list.

The Actions dialog box should look like this:

[ 2ctions " [ 2 i
Sedact type: Froperties:
Emulabenammand = || A Frmsdatiand smmand
SetTast + # Actian |
Emulatin{ smmand | oo [ R
+
|
% |
EmulaticnCommand
Rums the emaulation command.
K | Cancel |

13.Click OK.
14.Select File > Save Project.

Adding a Label control

Label adds a text label to a green screen. You can use Label to either replace an existing screen label or
create a new label.

1. In the history pane, select the SALES ORDER ENTRY - CUSTOMER SCREEN.

A larger version of the screen appears in the work area.

2. Drag the Label control icon from the control panel on to the work area and drop it on top of the
Contract field.

3. Size the control so it covers the field completely:
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N

. In the property grid, uncheck HostText.

The LabelText field appears.

In the LabelText field, delete the default text Label and type Date:

Select Right from the Alignment list.

In the ColorSettings frame, select FromHost under Background, and FromHost under Foreground.

N oo o

The control now uses the screen background and foreground colors for the label background and the
text. The label text is now visible in the control:

Cnbwiettiongy

CokonSstinguanription

8. Select File > Save Project.

Adding a Calendar control

Calendar inserts a selected date at a specified point on the screen.

1. Ensure the SALES ORDER ENTRY - CUSTOMER SCREEN screen is still displayed in the work area.
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2. Drag the Calendar control icon from the control panel on to the work area and drop it to the left of the

(new) Date field:

O - bi<rs Facat Sormen Casgue - —

"

3. In the property grid, click the accelerator button L) next to the InsertedDateFormat field.

©

The Date Format dialog box appears:

RN T
&-m«y i

MMM yyyy

Midfyyyy
Midlyy
MM/ddiyy
MM/ddiyyyy
dd/MM iy
yy/MM/dd
yyyy-MM-dd

Cancel
|

You can select from a variety of supplied date formats. Alternatively, you can specify a custom date
format.

Select MM-dd-yy from the list of dates, then click OK.

The dialog box closes and the date format appears in the InsertedDateFormat field.
In the Tooltip field, type Select date

Click the accelerator button L) next to the TextinsertionLocation field.

The Select Screen Location window appears.

Select Location from the Select By list.

Click one space to the right of the Contract field at screen location (3,52).
Click OK.

The window closes and the coordinates appear in the TextInsertionLocation field. In this case, 3,52.
The coordinates also appear in the status bar, below the property grid.
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When complete, the property grid looks like this:

4 Common
Name Calendarl
Inserted DateFormat MM/ ddfyyyy | |
Tooltip Select date
“ Action
TextinsertionLocation  JERM * k=l
BoundVanable il
4 Layout

Z0rder

10.Select File > Save Project.

Adding a GridCollector control

GridCollector gathers information from a specific screen location and displays the information in a table.

1. Inthe left pane, scroll down and select the EUROPEAN CUSTOMER LIST screen.
2. Drag the GridCollector control from the control panel and drop it at the start of the first row:

_ _

P Cwvctior - o Facas Soer. Cesgss

3. In the property grid, in the Name field, delete GridCol lectorl and type CustomerList.
4. Click the Edit icon [44 on the control.

The GridCollector frame appears:
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i OCLM REY  COUNTRY

Saecrten & czeed mars

5. Move and size the GridCollector frame so that it overlays the screen data:

P Curcilar: - W Facat Scrmen Dusguar

AGCOUNT

Saecrten & czeed mars

6. Click the accelerator button [ next to the Columns field.

The Columns dialog box appears:
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Calumn ftems Properties:

D Column - GrdCofectarColumn | ; ;Cnﬁnm({ridcmu{olumn
4 Mizc

-'i Hame GnidColeciorColumn

|“ o || caneel
— =

7. In the Name field, delete GridCol lectorColumn, and type Account.
8. Click the Add button |#/.

Another item appears in the Column frame.
9. In the Name field, type Sales Rep.
10.Click the Add button %/,

Another item appears in the Column frame.
11.Continue to add columns for:

« Vol/Yr
e Cum Rev
 Country

The dialog box should look like this:

Calumn Items: Properties:
U Columa - Account 4| | column GridCotectoeCalumn
1 Columan - Sales Rep Ml
2 Column - ValYr ;
3 Coma - Cum few X | I
4 Cobarna - GrdColectarCoburmn +

+

Marme
.3 ]u Cancel
= )| AAnes

12.Click OK.

The GridCollector frame now contains a number of blue vertical lines. These represent column dividers.
13.Drag each column divider to the left of each column.

The GridCollector should look like this:
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Tip: In some cases, such as Web applications, system parameters do not look for leading spaces.
= Itis therefore best to start a column on the first character of data.

14.At the top right of the GridCollector, click the Save icon .
15.Select File > Save Project

Adding a Table control

This section describes how to add a Table control to display the data collected by the GridCollector control.

1. Drag the Table control from the property grid and drop it on the GridCollector control.

The table automatically links to the GridCollector control and maps on to the area defined by the
GridCollector:

Note: The LinkedGridCollectorName field in the property is completed automatically, and the
table header and columns properties are taken from the linked GridCollector properties.
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2. Uncheck IsMoreButtonVisible.
3. Uncheck IsAutoNavigateOnlLoad.
4. Check IsExportButtonVisible.

y Note: The More button no longer appears in the table and is replaced by the Export button.

5. Select File > Save Project.

Adding a Collector control

Collector controls gather screen data for use in other functions. In this case you will add a Collector control
to collect data to generate a pie chart for January.

1. Inthe history pane, select the TOPCO TOYS, INC Revenue Analysis By Region screen.

2. Drag the Collector control icon from the control panel on to the work area and drop it on top of 305 in
the JAN column for region 1:

3. In the property grid, type R1Jtoy in the Name field.

This is the name of the variable where the value will be stored.
4. Leave TrimSpaces checked.

5. Add Collector controls for the three other regions. Use R2Jtoy, R3Jtoy, and R4Jtoy as global
parameter names.

The screen looks like this:
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TOPCO TOYS, INC

6. Select File > Save Project.

Adding a WebFrame control

In the previous section, you added four Collector controls to collect data for a pie chart. You will now add a
WebFrame control to use the variables of the Collector controls to generate the pie chart.

Note: In this section you use the WebFrame_URL . txt file and pie chart.png files supplied with
the package file.

1. Drag the WebFrame control icon from the control panel on to the work area and drop it just underneath
JAN:

2. Select Pop-up from the Mode list.

Note: If you were to select Embedded, the resulting pie chart would appear as an embedded
window on the green screen.

3. Click the accelerator button [z next to ImagePath.
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The Choose Image dialog box appears.

Click =] next to Add to pool.

Navigate to where you saved the pie chart.png file, select the file, then click Open.
Ensure the image is selected in the Choose Image dialog box and click OK.

In the Tooltip field, type Pie chart.

Open the WebFrame_URL . txt file.

© N o g &

The file contains the following URL:

http://chart.googleapis.com/chart?chs=300x150&cht=p3&chco=0000FF | OOFFQO0|
FFOO00O | FFFF00&chds=0, 1000&chd=t : %%R1Jtoy%% , %%R2Jtoy%%, %%R3JItoy%% , %%R4Jtoy%
%&chdl=Regionl]|Region2]|Region3|Region4&chtt=TOYS

9. Copy the content of the file and paste it in the URLSource field.
10.Select File > Save Project.

Adding a Tab control

Tab provides an area of the screen to which you can assign other controls. You can have multiple Tab
controls on a screen, with multiple Tab items within a Tab control.

1. In the history pane, select the SALES ORDER ENTRY - DETAIL LINE ENTRY SCREEN.

A larger version of the screen appears in the work area.

2. Drag the Tab control icon from the control panel to work area and drop it on the lower set of input fields,
then size the control to fit:

3. In the property grid, click the accelerator button (] next to the Tabltems field.

The Tabltems dialog box appears:
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0 Tab-Tab Hlem 4 [ Tabitem

[ Lanoel

o A

- Click the Add button |/,

Another item appears in the Properties frame.

~N O

- Click the Add button ¥/,

Another item appears in the Properties frame.

©

The dialog box looks like this:

Propeities
+ Tabltemn
+  Common
X Approved
+
*
Caption
Specifies the caption of the tab item
[#14 Lancel

9. Click OK.

The Tab control now as three Tab items:

Order Quantity | Approved

In the Caption field, delete Tab 1tem and type Order.
. In the Caption field, delete Tab 1tem and type Quantity.

In the Caption field, delete Tab 1tem and type Approved.

You can change the width of the tab item headers to fit the text you choose. For example, the default
width is eight characters. You can specify a different width by changing the value in the HeaderSize

field in the property grid.
10.Change the value in the HeaderSize field to 12.

You can see the change in the width of the tab item headers.
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Note: If you select Dynamic from the HeaderWidth list, the headers automatically size to fit the
length of text in each header.

1Ln the ColorSettings frame, select Custom under Background, then click the down button B to open
the Available Colors palette.
12.Select RoyalBlue:

Fuailable Colors

|| | ! RoyalBlue F

Standard Colors

[ Advanced |

The color fills the Tab control and its Tab items:

e | quanoty | _dperoved |

13.Select File > Save Project.

Adding an InputField control

InputField provides a text input field in which you type text at a specific screen location.

1. Each input field requires a label. Drag the Label control icon from the control panel and drop it onto the
Tab control you have created:

oner | Quantity | ppraved

2. In the property grid, uncheck HostText.

The LabelText field appears.
3. Inthe LabelText field, delete the default text Label and type Order Number:.
Add another Label control below the first and call it Status:.
5. Size both labels:

P

Cirler uanbty I-.lmlmﬂ
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6. Drag the InputField control icon from the control panel and drop it on the Order Number row:

e Cruantity Approved

7. Click the accelerator button [ next to the TextinsertionLocation field.

The Select Screen Location window appears.
8. Select Location from the Select By drop-down list.
9. Click in the Order Number field, then click OK.

The coordinates 3,16 appear in the TextlnsertionLocation field.
10.In the ColorSettings frame, select FromHost under Background, and FromHost under Foreground.

The control now uses the screen background and foreground colors.

The Tab item currently looks like this:

e Cuantity Approved

11.Click the Quantity tab.

12.Drag the Label control icon onto the tab item.

13.Uncheck HostText and call the label Product Number:.
14.Size the label.

15.Add another label below the first, call it Quantity:, then size it.

The Tab item should look like this:

16.Add an InputField control on the Product Number row.

17.Click the accelerator button [ next to the TextinsertionLocation field to open the Screen Location
window.

18.Select Location from the Select By drop-down list.
19.Click in the Product Number field, then click OK.

The coordinates 6,18 appear in the TextlnsertionLocation field.
20.In the ColorSettings frame, select FromHost under Background, and FromHost under Foreground.
The control now uses the screen background and foreground colors.

21.Add an InputField control on the Quantity row.
22.0pen the Screen Location window and click in the Order Qty field.

23.Click OK.

The coordinates 8,18 appear in the TextInsertionLocation field.
24.1n the ColorSettings frame, select FromHost under Background, and FromHost under Foreground.
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The Tab item should look like this:

ke Duanay Approved

25.Click the Approved tab.
26.Drag the Label control icon onto the tab item.
27.Uncheck HostText, call the label Approval :, then size the label:

ower | guanuty | Approves

28.Select File > Save Project.

Adding a RadioButton control

RadioButton sends text to a specified screen location.

This section uses the Tab control you created previously.

1. Click the Order tab:

Order Cruantity Approved

2. Drag the RadioButton control from the control panel and drop it on the Status row:

Onder Cuantity Approved

In the property grid, delete RadioButton from the Caption field and type Open.

In the GroupName field, type OrderStatus.

Open the Screen Location window from the TextinsertionLocation accelerator button.
Select Location from the Select By drop-down list.

Click in the Status field on the top row of the green screen.

Click OK.

The coordinates 3,33 appear in the TextlnsertionLocation field.
9. In the SelectedState > TextToSend field, type Open.

© N o g s~ w

The property grid should look like this:
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4 Common

Mame RadicButtonl
Caption Cpen
Tooltip
GroupMame OrderStatus
IsVisible
4 Action
BoundVariable A
4 Actions
Textlnsertionl... 3,33 A E]
4 SelectedState
TextToSend Open
Actions (Collection) E]

10.Drag the RadioButton control from the property grid and drop it below the Open radio button:

et Cuuantity

Approved

11.In the property grid, delete RadioButton from the Caption field and type Shipped.
12.In the GroupName field, type OrderStatus.
13.0pen the Screen Location window from the TextinsertionLocation accelerator button.
14.Select Location from the Select By drop-down list.
15.Click in the Status field on the top row of the green screen.
16.Click OK.
The coordinates 3,33 appear in the TextlnsertionLocation field.
17.In the SelectedState > TextToSend field, type Shipped.
18.Click the accelerator button [::] next to the Actions field.
The Actions window appears.
19.Select Email from the Select type list, then click Add.
20.In the ActionTarget field, type: customer@address.com
21.Click OK.

The tab item should look like this:

e Cruantity

Approved

22.Select File > Save Project.

Adding a CheckBox control

CheckBox acts like an on/off toggle in the same way as a typical check box.

This section uses the Tab control you created previously.
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9.

Click the Approved tab:

Order | Quanity | Approved

Drag the CheckBox control from the control panel and drop it on the Approval row:

Order | Quansty | Approwed

In the property grid, delete CheckBox in the Caption field and type Approved.
Open the Screen Location window from the TextinsertionLocation accelerator button.
Select Location from the Select By drop-down list.

Click in the Status field on the Line Number row, then click OK. The coordinates 5,57 appear in the
TextlnsertionLocation field.

In the CheckedState > TextToSend field, type Approved.
In the UnCheckedState > TextToSend field, type Pending in the TextToSend field.

The property grid should look like this:

4 Common

Mame CheckBoxl
Caption Approved
IsVisible
Tooltip
< Action
BoundVariable d
4 Actions
TextInsertionl... 557 A E]
4 CheckedState
TextToSend Approved
Actions (Collection) E]
4 Unchecked5ta...

TextToSend Pending

The tab item should look like this:

Order | Quasaiy | Aopraved

Select File > Save Project.
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Adding a MultiLine control

The MultiLine control is a text input field with multiple lines into which you type text which is inserted at a
specified screen location. For example, MultiLine can be used to modernize or rationalize the layout of a
screen with input fields that contain more than one line.

1. Drag the MultiLine control from the property grid and drop it on the work area next to the Address
label.
2. Use the control's handles to widen the control and make it two rows deep:

e T )
B ermoHont - Wicro Focus Screen Cesigner ==

Open the Screen Location window from the TextinsertionLocation accelerator button.
Select Location from the Select By drop-down list.
Click in the Address field at row 7, column 16, then click OK.

o oMW

In the ColorSettings frame, select Custom under Background, then click the down button E| to open
the Available Colors palette.

7. Select RoyalBlue.

The color fills the MultiLine control.
8. Select Custom under Background, then select White in the Available Colors palette.

This will be the text color in Plus mode.
9. Select File > Save Project.

Taking the project live
Now the customization project is complete, you need to:

+ Create a Plus archive.
* Associate the archive with a mainframe session.
* Test the screens.
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Creating a Plus archive

You must now save all the controls and rules you have created to a Plus archive. You will then link the
archive to a mainframe session.

To generate the Plus archive:

1.

2.
3.
4.

Select Create > Plus Archive.

The Save Plus Archive dialog appears.

In the File name field, type a name for the file, such as DemoHost.
Click Save.

Select File > Exit.

Associating a customization file with a host session

The final step is to associate the customization file with a host session. To do this:

1.

On the Reflection desktop, select Appearance tab > Plus group > Plus > Select Plus Plus Archive.
The Open dialog box appears.

Choose the Plus archive you created, then click Open.

Plus mode is enabled automatically.

Testing the screens

1.

2.

Select Session tab > Connect.

The mainframe screen appears in Plus mode, showing the controls you added to it:

| & F el & e Reflection Wirkspace - [Dema Hest id3a] = ]

[ G -
Fo. T HF & WD ég M5 B

o Sounia

| & ®iDema Host

Hover your mouse over the Micro Focus button.

The tooltip text you created appears:
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3. Hover your mouse over ENTER SYSTEM 1D:

The tooltip text you created appears:

4. Select TSO MVS/XA from the Chooser control. The AutoExecution action you specified in the Chooser
automatically sends an Enter command to execute the system selection. The additional AutoExecution
controls you created send Enter commands automatically at the ENTER LOGON ID: and LAST
SYSTEM ACCESS prompts, presenting you with the READY prompt screen, the image you added with
the Image control, and the message box you created:

@ DFda - Reflection Warkspace - [Demo Host.id3s] o (=) |
“ Session  Appesrance ool Macros G v
Fomt: S e - Fm e . =1
| . H O W8 é 4 =
b o Cisor ~ WiScnds . UiDesgrer Contex: Mes Model Hotspols CodefFage | | iaabls | P il Kavkond

Conmected to the kst [Semo:plus3a P sm] Num wszam | 3| W™ -

5. Do one of the following:

* Click Cancel. This logs you off and you will need to start the session again.
* Click OK to continue.
6. Atthe READY prompt, enter:

0
The SALES ORDER ENTRY CUSTOMER SCREEN appears:
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O BFdd - Reflection Workspace - [Demp Host.rd3s] = | (B, e |

- =
Font: Sara: = - E. - e
% Ge:l'.e.'."cx.' ﬁ "{:’ 'q% “\. E“ ¥ i I;E—:-' |
niexs Me Hoded H able | P

Conmected to the host [Semo:plus3a Psm] NUM

This screen contains the Date label, Calendar, and MultiLine controls you created:

7. Hover your mouse over the Calendar control.

The tooltip text you entered appears:

8. Click the Calendar control.

A calendar appears:

4 March 2017 F
Mo Tu We Th Fr Sa Su
2] I Bl Z 3 4 5

&5 7 & 9 10 11 1

2
13 14 15 16 17 1 19
5

20 21 22 23 24 2% 26

9. Select today's date.

The date appears:
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NERA B3/01/17

10.Click inside the MultiLine control. Type an address of your choice. Press Alt+Enter to split the line into

two.

The text is inserted on the green screen, starting at the row,column location you specified in the Screen

Designer.
11.Press PF3.
12.At the READY prompt, enter C.

The EUROPEAN CUSTOMER LIST screen appears, showing the table you created with the

GridCollector and Table controls:

o I Reflection Wirkspace - [Dema Heat ifa] | 0 i |

FPo. T ¥ & RQ4[ES B8

| onnected to the hes [demo gl 12 Tsm| Hum xmpm | 0 W -
L

13.Click Export at the top right of the table.

The Save As dialog appears.

14.Specify a name for the table and click Save. The contents of the table are saved in .CSV format.

15.Press PF1.
16.At the READY prompt, enter:

TOYS
17.At the TOPCO TOYS, INC screen, click the WebFrame control under JAN.

The pie chart you created appears in a separate window:

u

i Soreen Designer WebFrame L __iﬁs-fi

TOYS
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18.Close the pie chart window.
19.In the TOPCO TOYS, INC screen, press Enter.
20.At the READY prompt, enter:

0

The SALES ORDER ENTRY CUSTOMER SCREEN appears.
21.Press PF8.

The SALES ORDER ENTRY DETAIL LINE ENTRY SCREEN appears, showing the Tab control you

created:

(@ haasz- T i Wotsas D et 3 R P
s B Dt -
.. T #F OH mQ & MF B

| 8 Finemo Host

Order Number :

Connecied fo e hosd [demo gl 1270 sim| LW xapm 00 B -

22.0n the Order tab item, in the Order Number field, type 12345.

The number appears in the Order Number field on the green screen.
23.Select the Open radio button.

The text Open appears in the Status field next to the order number:

Order Humber: 12345 Status: Open
24.Select the Shipped radio button.

The text Shipped replaces Open in the Status field:

Order Humber: 12345 Status: Shipped

Your default email client opens a new message window so you can advise the customer that the order
has shipped.

25.Click the Quantity tab.
26.In the Product Number field, type ABC77701.

The text appears in the Product Number field.
27.In the Quantity field. type 25.

The text appears in the Order Qty field:
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28.Click the Approved tab.
29.Check Approved.

The check box is unchecked and the text Pending appears in the second Status field.

30.Check Approved again.

The check box is checked and the text Approved appears in the second Status field.

The screen looks like this:

31.Select Session tab > Host group > Disconnect.
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Using the Rule Manager

Use the Rule Manager to add dynamic controls that repeat on multiple screens or many times on a single
screen.

When to use the Rule Manager

The following basic scenarios describe when to use the Rule Manager instead of the Screen Design view.
e Adding Tooltip or Button controls to entire applications.

Fields with specialized Tooltip controls or assistance which remain consistent within the application.
Especially useful to explain account, customer, and status information that is abbreviated or appears in
abbreviated form on the screen.

Buttons such as Exit, Clear (screen), and Reset (keyboard).
« Adding controls to screens within subsystems.

Controls which are consistent with major subsystems such as accounts payable, help ticket systems, or
customer lookup. A subsystem might consist of five to ten screens, but operator functions are consistent
throughout.

Screen content can change, but header information needs to offer similar modernization control.
« Data scroll areas with modernizations that repeat on each line.

One Plus rule can create multiple modernizations.

) Tip: If you find that a control in the Screen Design view might be used better as a rule, right-click
= the control and select Convert To Rule from the pop-up menu. The Screen Designer moves the

control to the Rule Manager.

The Rule Manager window

To open the Rule Manager window, select Tools > Rule Manager from the Screen Designer toolbar.

The Rule Manager window appears:
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FE Rule Manager l_[‘l_ﬁ
. 3 Mew Rule List of rules
| Narme & N
# Create Hotspots =
{3 Create Translated Labels L]
1) &
Rule description -
O
.1‘
Close
#! Control panel. Contains a list of the following actions:
New Rule Opens the Rule Wizard to create a new rule.
Edit Rule Opens the selected rule in the Rule Wizard for editing.
Delete Rule Deletes the selected rule.
Enable Rule Enables the selected rule, if disabled.
Disable Rule Disables the selected rule.
Duplicate Rule Creates a copy of the selected rule.

The control panel also contains a search box to search rules.
f* List of rules pane. Contains a list of configured rules. Each rule consists of:
e A description.

An icon to use the rule to filter screens

An icon to show whether the rule is enabled 5
An icon to show whether the rule is disabled B
An icon to edit the rule o

. (5}
An icon to delete the rule

‘:3 Rule description pane. Displays a natural language version of the rule.

The Rule Wizard

The Rule Wizard helps you to define rules and conditions that govern what actions occur on a screen and
when.
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P8 Rule Wizard 19 o]

® Empty Rule :

[1E] Find ol fields that contain the "§' sign and collect the tewt, unless the screen is confidential.

iE] Create a Chooser control on 8 screen with a specific hint abowve specific text,

Choose condifions when

BCTBEDN & ars & E
PP 5] Create Hotspots .@ 1

(=] Create s Button control that sends PF3 on the upper left comer of every screen.
Step 3

Select screen data to search for [=] Create & Tooltip control for & specific field on & specific screen

=] Create Translated Labels

Step 4
Choose the nule actions X
Rule name |
Step 5 -
Chibose exgeptions when

screen appears Rule description

When ary new screen agpears

) ®

[ Concel Next> |
7% Steps pane. Contains the steps you need to go through to create a rule. The current step is
l’ highlighted.
1:’ Options pane. Contains the options available for the selected step:
When this step is highlighted ... The options pane contains ...
Step 1 A list of templates that you can use to build
arule.
Step 2 Conditions that identify the screen the rule
will apply to.
Step 3 The field, location, or text to look for on the
screen.
Step 4 The controls to create according to the rules.
Step 5 Exceptions to the rules that select screens.
E., Rule description pane. Contains a natural language version of the rule.
Examples
The following examples show different ways in which you can use the Rule Manager to design modernized
screens.

Adding Button or Tooltip controls to entire applications

A simple system Clear button is designed with a rule that places it on every screen of the application in the
top right corner.

Button controls like this help users who are not used to the rules that apply to 3270 / 5250 applications.
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Rule description
When any new screen appears
then find screen rectangle from rowel column: 6 with swe:l. 5

create a Button for each item found a4

WELCOWE TD THE MICROD FOCUS EIT CICS/TS SERVER 3.1 REGION 18:82:15

\

Adding controls to screens within subsystems

In this example, the administrator wants to help users identify an account status. Anywhere in the
application where the string ACCOUNT STATUS : AB appears, a tooltip appears so that the operator
knows that the account status is active with credit approved.

The rule first finds the character string, then places a tooltip over the entire string. Moving the mouse over
the abbreviated field provides a more detailed description.

Rule name | Active Billing

arnen

Rule description

Wihen a new screen appears
and the soreen containg "Account Statws : AR' somewhere on the screen 2 A
then find 'Account Status : AE' on screen = 2 ’(
create a Tooltyp for sach tem found H

i #fccount Mumber :  333-333-3333

_ Residential Account Profile

Adding rules to be used on a set of screens

This example shows three screens in an application called Master Inquiry. The screens are similar, but
have different input prompts and different data headings. Each screen would be identified automatically as
a different screen.
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The example creates a rule that puts a Create New Customer button near the first entry field.

The rule for this button is based on the Master Inquiry screen designation. If the screen identifies itself as
Master Inquiry and the string 5=display is found, the rule automatically puts a button by the
5=display field. On screens that do not match the criteria, no button is created. The button is
programmed with the keystrokes to create a customer record within the application.

Rule name | Master Inquiry Create
wessn
Rule description
When a new Loréen appeart
and the screen contains MASTER INQUIRY " in rowl column:26 - ,.{
then find “S=display an scraen - x
create a Button for each item found »

[ mrare| Mot = Finich

Name: M
.

Firr r
Appleseed
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Adding controls to each line on a screen

This example uses screens containing tables of data and adds the same controls to each line on the
display. If you were to use the Screen Design view, you would need to add a separate control for each line
of each table. Instead, you can use rules to replicate controls on each line.

To select a customer, the user types 1, then presses Enter. The example sets up a rule that replaces these
actions.

Note: The number of data entries per page varies. The rule creates 10 static selections per page. As
a result, the last page will only have three buttons because only three selections are valid.

The rule looks for the character strings Select Customer and 1 Select. It then replaces the single
character input field with a button labeled SEL. This button replaces the two actions of typing 1 in the data
field and pressing Enter with a simple point and click.
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Rule name | Select a Customer
EEEEED

Rule description

When a new screen appears
angd the screen contams 'L=5elect’ m roweB columned 3 == ' x
and the sereen contains ‘Select Custamers’ in roweS eolurmn:s3 = K
then find Unprotected and visible field with text: ' r x
eraabe & Buttan for aach item found x

Lance MNext » Forush |

Because the rule looks for the input field, if that input field is not found, the control is not added to the
screen.

Using operands in rules

In this example, the administrator wants to identify all employees who joined the company from March,
2010 and earn less than 40,000 a year, then mark each screen with a label.

This rule looks at either of two screens for salaries under 40,000 and dates after March 1, 2010. If both
types of data are found, a label is placed on the screen:
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Rule name | Operand Rule

Rule description
When a new screen appears
and Screen 1D is ResCurrentProfile
or Screen ID is ResBasicSumrmary
L4

and the screen contains Number that is LessThan 4 n rowd column:l3

and the screen contains Date that is GreaterThan '( 010" in row:14 columm:5

then find screen rectangle from rowed columncE with size:3, 10

KK HXAXKX

create a Labsl for sach tem found

Using variables in rules

This example uses a variable to display a message box if a value exceeds a specified amount. If the
outstanding balance on a customer account screen exceeds 25, a message box appears to alert the user.

A Collector control is used to read the value of the appropriate field:

The rule first looks for the correct screen ID, then reads the value of the selected variable provided by the
Collector control.

Rule name | Tatal Outstanding Alert

Rule description
When a new screen appears
and Sereen [D is ResCurrenthocount

and vanable total_os with Number that is GreaterThan "25'

X XX

create & MessageBox for each item found

If the value exceeds 25, a message box is displayed:

Using the Rule Manager | 57



2 1 .
t Number

Warning

Man

Frafile

PF1=Helr 2=Helcome
PF7= B=
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Types of Control

AutoExecution

AutoExecution is used to trigger a sequence of actions when a green screen appears. The control is not
visible in a Plus session.

Button
Button is used to trigger a sequence of actions when clicked. The control can include text or an image.
Properties:
Name Default value Description
Mode Text Specifies the type of content for the control. Can be Text
or Image.
Note: If you select Text, you can create a new line
or split an existing line by pressing Alt+Enter.
ImagePath Empty string Click the accelerator button to open the project image
pool folder where you can select an image file with a
format of JPG, GIF, or PNG. To select a different image,
click Add to pool and browse to the image you want to
use. The image file is then copied to the image pool and
saved with the project.
Alternatively, you can type the location of an image in the
form of its full path or full Web address in the ImagePath
field.
Only available if Mode is Image.
ImagePosition Stretch Specifies the position of the image inside the button:
Stretch (default)
Fill
Fit
Center
Calendar

Calendar is used to pick a date and is initially displayed on the screen as an icon. Calendar opens when
you click the icon. It closes on losing focus, or when you select a date.

When you select a date in the date picker, the date is inserted on the screen at the coordinates defined by
TextInsertionLocation. The format used is defined by InsertedDateFormat.

If the field occupied by Calendar contains date, the field is used by Calendar when it opens. Otherwise,
Calendar uses the current date.
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Note: When the control is used in a Plus session and, if the screen location is a protected field, the
calendar can be displayed but no date can be picked.

Properties:
Name Default value Description
InsertedDateFormat Empty string Specifies the format of the text representing the date

format.

If empty, the default date format is used:
dd/MM/Zyyyy

For example, 03/01/2015.

Using the Date Format dialog box

Use the Date Format dialog box either to select a predefined date format or to create a customized date
format.
Selecting date formats

To select a date format other than the default:

1. Click the accelerator button [J next to the InsertedDateFormat field in the property grid.

The Date Format dialog box appears.
2. Select a date format from the list shown, then click OK.

The dialog box closes and the chosen date format appears in the InsertedDateFormat field.

Using customized date formats

To use a customized date format:

1. Type the format you want in the field at the top of the Date Format dialog box.

Note: Day and year must always be specified in lower case. Month must always be specified in
upper case.

2. Click Add.

The custom format appears in the main list.
3. Click OK.

The dialog box closes and the chosen date format appears in the InsertedDateFormat field.
4. To remove a custom format from the list, select the format, then click Remove.

f Note: You can only remove custom formats, not a supplied format.

Custom date format specification

The table below describes the date formats you can use with the Calendar control.

Format specifier Description Example Interpretation

j Represents the sequence  j-yy The date 1/1/2015, j is
number of a day in the displayed as 1-15.

calendar year. vy

The date 12/31/2015,

j displays values between 1, j is displayed as 365-2015.
which represents January
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Format specifier

Description Example

Interpretation

i

dd

ddd

dddd

MM

1, and 366, which
represents December 31 in
a leap year.

Represents the sequence  jjj-yy
number of a day in the
calendar year. NEYYYY
jjj displays values between

1, which represents

January 1, and 366, which
represents December 31 in

a leap year.

For jjj, values less than 100
are padded with a leading
ZEero or zeros.

The day of the month, from  M/d/yyyy

1 through 31. Midlyy

The day of the month, from  M/dd/yyyy
1 through 31. M/ddlyy

The abbreviated name of M-ddd-yyyy

the day of the week. M-ddd-yy

The full name of the day of M-dddd-yyyy
M-dddd-yy

the week.

The month, from 1 through M-dd-yyyy
12.

The month, from 01 through MM-dd-yyyy

12.

The date 1/1/2015, jjj is
displayed as 001-15.

The date 12/31/2015, jjj is
displayed as 365-2015.

For the date 6/1/15, d is
interpreted as 1.

For the date 6/15/15, d is
interpreted as 15.

For the date 6/1/2015
dd is interpreted as 01.
For the date: 6/15/15
dd interpreted as 15.

For the date 6-Mon-2015,
ddd is interpreted as Mon
(for EN-US).

For the date 6-lun.-15, ddd
is interpreted as lun. (for
FR).

For the date 6- Monday
-2015

dddd is interpreted as
Monday (for EN-US).

For the date 6- lundi -15,
dddd is interpreted as
lundi (for FR).

For the date 6/15/2015, M
is interpreted as 6.

For the date 12/15/2015, M
is interpreted as 12.

For the date 06/15/2015,
MM is interpreted as 06.

For the date 12/15/2015,
MM is interpreted as 12.
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Format specifier Description Example Interpretation
MMM The abbreviated name of MMM-dd-yyyy For the date Jun-15-2015,
the month. MMM is interpreted as Jun
(for EN-US).
For the date juin-15-2015,
MMM is interpreted as juin
(for FR).

MMMM The full name of the month. MMMM-dd-yyyy For the date
January-15-2015, MMMM
is interpreted as January
(for EN-US).

y Represents only the last M-dd-y For the date 2-03-15, y is

digit of the year. interpreted as 5.
When the Calendar control
is opened by the user, the
digit of the current decade
is added to the left. That is,
the year would be set to 15
(2015)

vy The year, from 00 to 99. M-dd-yy For the date 6-15-15, yy is
interpreted as 15.

yyyy The year, as a four-digit M-dd-yyyy For the date 6-15-2015,

number. yyyy is interpreted as 2015.

Any string Data separators. Examples:

M dd yyyy
M-dd-yyyy
M/ddlyyyy
M#dd#yyyy

CheckBox

The CheckBox control acts as an on/off toggle control in the same way as a typical check box.

CheckBox provides the user with the choice of one of two options, such as Yes and No.

Note: When the control is used in a Plus session and, if the screen location is a protected field, the

control is disabled.

Properties:

Name Default value Description

CheckedState Empty string The text to be used at the specified screen location and
any specified actions to be performed if the check box is
checked.

UnCheckedState Empty string The text to be used at the specified screen location and
any specified actions to be performed if the check box is
unchecked.
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Chooser

Chooser is displayed on the screen as a drop-down control. Chooser is used to insert data into a field on
the screen by selecting an item from the list.

Auto-complete is supported.

Note: When the control is used in a Plus session and, if the screen location is a protected field, the
control is disabled.

Properties:

Name Default value Description

IsAutoCompleteEnabled  Checked When checked, Chooser automatically offers a case-
insensitive matching item to be selected from the list. If
the user is not typing in the screen field occupied by
Chooser, no suggestions are made.

IsEditable Checked When checked, data can be typed into the field that
Chooser is using. If unchecked, data can only be selected
from the drop-down list.

UseDynamicData Unchecked When checked, the items list is taken dynamically from
a .CSV file. The .CSV file can be a local file, a network
file, or a URI.

Chooserltems Empty list The list of items displayed by the drop-down list when
clicking the down arrow. The list of items can be imported
from a . CSV file (see below). Each item is specified by
Caption, Tooltip, and ValueTolnsert. If
UseDynamicData is checked, the Chooserltems field
contains the full path of the .CSV file or opens a dialog
box to select it.

ValueTolnsert Specifies the text to be inserted when selecting an item
from the list.

Using a .CSV file to supply data

When UseDynamicData is checked, the list of Chooserltems is taken from a .CSV file. The file can be a
local file, a network file, or a URI. The Chooserltems field contains the full path of the .CSV file, which you
select by clicking the accelerator button.

To use this feature successfully, the contents of the .CSV file must be in the following format:
<CAP><DEL><TI| P><DEL><VAL>

where:

This ... Denotes this ...

<CAP> Caption.

<DEL> Tab, comma, semi-colon.
<TIl P> Tool tip.

<VAL> Value to insert.
Examples:
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Tab Comma Semi-colon Single column
AAA AAA, BBB, CCC AAA AAA
BBB DDD, EEE, FFF B;B;B BBB
cccC GGG, HHH, Il C,CC CcC
DDD JJJ, KKK, LLL D;D;D DDD
MMM, NNN, OOO EEE

Loading data from a . CSV file:

Check UseDynamicData in the property grid.

Click the accelerator button next to Chooserltems.

In the Open dialog box, find and select the .CSV Chooserltems file.
Click Open.

P wDh PR

Importing a . CSV file:

1. Leave UseDynamicData unchecked.

Click the accelerator button next to Chooserltems in the property grid.
In the Chooserltems dialog box, click the Import icon.

Select the .CSV file.

Click OK.

a s~ wDd

Loading data dynamically in a Plus session

You can use a URI to supply data from a remote source to a Chooser control during a Plus session. The
source can be a .CSV file or a web service that returns .CSV formatted output.

The content of the Chooser is loaded dynamically and cached into the project folder each time the screen
containing the Chooser appears.

1. Check UseDynamicData in the property grid.
2. In the Chooserltems field, type the URI of the data source. For example:

http://www.<donai n>.com/<ser vi ce_nane>7?<par anet er >=<val ue>

y Note: If the URI is not accessible for any reason, the cached data is used.

Collector

Collector is not visible in a Plus session. It is used to copy text from the screen location of the Collector to
the session database. The screen location of the Collector is defined by the two pairs (Row Offset,
Column Offset), (Row Span, Column Span).

The database lifetime is the whole session. Data is collected when host screen appears as a list of (key,
value) pairs of strings. The data can be used by other controls only from the current session. When the
screen location of the Collector spans screen rows, appropriate line breaks are inserted into the collected
data.

For example, a Button control looking like a small handset icon can be set up with an action
Run_Application to run Skype. Additional_Arguments of this action can use a phone number stored by
the Collector located in a phone number field on another screen of the session.

Properties:
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Name Default value Description

TrimSpaces Checked When checked, all leading and trailing whitespace
characters are not copied to the database. When
unchecked, whitespace characters are included in the
data.

Note: The Name property also specifies a key to be used by a Collector when copying data from the
Collector screen location to the database.

Data stored with the same key more than once is overwritten.
Data can be accessed later in the session by using the syntax:
%%PhoneNumber%%

where PhoneNumber is the global variable name.

GridCollector

The GridCollector control is an extended version of the Collector control. Collector collects data as text
from a specific screen location. GridCollector collects data as a table (grid).

The control stores the collected information in a database for the lifetime of the current session. The
information can be used by any other control.

To configure GridCollector properties, click the Edit Mode button at the top right corner of the control.
When you have finished, click either the Save and Exit button or the Cancel Edit Mode button.

Properties:
Name Default value Description
Columns GridCollector Column Columns collection. Each column has one property:
Name: Non-empty string.
IncludesHeader Checked When checked, the selection includes the table header.
AvoidDuplications Checked When checked, duplicate rows are not collected.
MultiPageNavigation Checked When checked, the following properties are enabled:
MaxPagesToLookUp
ForwardNavigation
BackwardNavigation
MaxPagesToLookUp 1 Integer. The number of additional pages that are fetched

ahead each time the fetch operation is triggered by one of
the controls that uses the GridCollector data. The
GridCollector implements the fetching mechanism (not
the control that uses the GridCollector) .

ForwardNavigation
AidKey PF8 The AID key for fetching the next page.

EndOfDataConditions Clicking the accelerator key opens the
EndOfDataConditions dialog box.

BackwardNavigation
AidKey PF7 The AID key for fetching the previous page.

EndOfDataConditions Clicking the accelerator key opens the
EndOfDataConditions dialog box.
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Name Default value Description

SaveCommand Executes an action or a collection of actions when the
Save button is clicked on the linked table. Clicking the
accelerator button opens the SaveCommand dialog box
where you specify the actions to be executed.

Refreshing data

If you have specified an action to be performed in a table and that action is relative to a row, a refresh might
be required to synchronize the table data with the data collected from the green screen. To specify a
refresh, you can tell the associated GridCollector control to go back to the first table screen and collect any
data again. To do this:

1. Click the Edit icon on the GridCollector control.

2. In the property grid, under BackwardNavigation, select a PF key from the AidKey list to use as an AID
key. The default is PF7

3. Under BackwardNavigation, click the accelerator button next to EndOfDataConditions.

The EndOfDataConditions dialog box appears.

4. From the Select type list, select the stop condition to determine the first page of the table, then click
Add. The default condition is Timeout.

5. Click OK.

EndOfDataConditions properties

Name Default value Description

Timeout When selected, data collection stops if no response is
received within the value specified by
WaitForResponseTimeout.

WaitForResponseTimeout 2000 Timeout, in milliseconds. Minimum value is 500 ms.
Maximum value is 10000 ms.

EmptyLine When selected, data collection stops if an empty line is
found.
Text When selected, data collection stops if either:

The specified non-empty string is found at the specified
screen location.

or:

The specified string is empty and nothing is found at the
specified screen location.

EndOfDataText The text to search. Available if Text is selected.
EndOfDataTextLocation Anywhere Location of the text. This is one of the following:

e The whole screen, as specified by the string
Anywhere.

» A specific location on the screen, specified in the
Screen Location dialog box. To open this dialog box,
click the accelerator button next to the
EndOfDataTextLocation field.

EndOfDataTextRow The row of the text.
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Name Default value Description

EndOfDataTextColumn The column of the text.

Note: GridCollector checks stop conditions from the top to the bottom of the list until any condition is
met, then stops collecting data. In this way, you can re-order conditions to collect different amounts of

data from the same screens.

Syntax

Any control that wants to use the data from the GridCollector can get the data by using the following
syntax:

%%GridCol lector_Name[Row_Number,Column_Name]%%

Examples:
%%Customers[5,Address]%% Defines getting the address of the entry 5.
%%Customers[*,Address]%% Defines getting the address of all customers. This can be
useful for setting a list control's items source.
%%Customers[3, *]%% Defines getting all data for the customer at the third row.
%%Customers[*, *]%% Defines getting GridCollector data for all customers.

On a Plus screen, each time new data appears on the screen, the data is added to the GridCollector table.

Image

Image control is used to mask an area on the screen. The control appears in a Plus session without a
frame, and can be filled with one of the following:

Image If you do not select a valid image, or provide a valid URL, the Image control is invisible on the
screen.

Color You can either use the host background color as the fill color (default) or select a custom color
from the palette. The default color is black. If you select a transparent fill, the Image control is
invisible on the screen.

You can change the opacity of the Image control to show the contents of the screen behind the control. To
do this, select the control, then click the icon on the top right corner of the control's frame.

Properties:

Name Default value Description

Type Image Fill type. Can be one of Image or Color.

ImagePath Empty string Click the accelerator button to open the project image

pool folder where you can select an image file with a
format of JPG, GIF, or PNG. To select a different image,
click Add to pool and browse to the image you want to
use. The image file is then copied to the image pool and
saved with the project.

Alternatively, you can type the location of an image in the
form of its full path or full Web address in the ImagePath
field.

Only available if Type is Image.
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Name Default value

Description

ImagePosition Stretch

ColorSettings
Background Black

Position and size of the selected image. Can be one of
the following:

Stretch (default)
Fill

Fit

Tile

Center

Only available if Type is Image.
Only available if Type is Color.
Specifies the fill color of the control. This can be one of:

¢ FromHost: The host background color is used.
« Custom: You select a color from the color palette.

InputField

The InputField control provides a text input field in which the user types text which is added at a specified

screen location.

For example, InputField can be used to modernize or rationalize the layout of a screen with a number of
input fields. InputField controls can be placed where they are most useful. The information the user types
into them is then added at the screen locations of the traditional editable areas.

Note: When the control is used in a Plus screen, the input field displays the value from the screen
location, at the specified length. However, if the screen location is a protected field, no typing is

allowed in the InputField control.

In addition, if the length is 0 (the default value), data is read until the end of the green screen field the
control refers to, and the number of characters is limited by the length of the green screen.

Properties:

Name Default value Description

IsEnabled Checked Specifies whether the control allows user input.

IsNumeric Unchecked Specifies whether the input is numeric as opposed to all
characters.

IsPassword Unchecked When checked, a mask character (*) is displayed instead
of the typed characters.

Length 0 The maximum number of characters that the input field
can contain. A value of 0 means the number of characters
is limited by the length of the green screen field.

AutoTab Unchecked When checked, and the length of inserted text reaches
the length of the input field, the cursor moves
automatically to the next field control, as defined by the
TabOrder property.

Label

The Label control is a single line control which is used to place any static text at a specified location on a

screen.
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Properties:

Name

Default value

Description

HostText

LabelText

TranslateText

TextLocation

TextLength

Alignment

Checked

Label

Unchecked

InPlace

Left

When checked, the host text located at
(StartRow,StartColumn) is used as the label text. When
unchecked, LabelText is made available.

If HostText is unchecked, this specifies the custom text to
be displayed on the label.

Note: You can create a new line or split an
existing line by pressing Alt+Enter.

When checked, the label text is translated using the
language file specified in the Project Settings window.

The (row,column) where the label text on the screen
should be taken. InPlace means the label text should be
taken from the location of the control as specified on the
Screen Design page, or from the location of the logical
marker defined by the SearchFor condition.

The screen location can also be defined by using the
Select Screen Location window, opened by clicking the
accelerator button next to the TextLocation field.

Specifies the number of characters in the label text.
Specifies the alignment of the label text:
Left

Center
Right

Translating Label text

You can specify that the text of particular Label controls are translated to another language. To do this, you
need to create a translation resource file, which is a . csv file containing semi-colon delimitered strings.
You then configure the Label controls.

Configuring Label translation

1. Create a translation resource file in the following form:

<sour ce_l anguage_phrase>; <target | anguage_ phrase>

<sour ce_l anguage_phrase>;
<sour ce_l anguage_phrase>;

<sour ce_l anguage_phrase>;

<t arget | anguage_phrase>
<t arget | anguage_phrase>

<t arget | anguage_phrase>

<source_l anguage_phrase; <target | anguage_phrase>

2. Save the file as a .csv file.

3. Select Tools > Project Settings.

The Project Settings window appears.

4. Select Translation in the left pane.

5. Click Browse next to the Translation File field.

The Select Translation File window appear.
6. Select the appropriate file and click Open.
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Note: You can also type a URI in the Translation File field. The URI can contain parameters, such
as login credentials. For example:

https://<user i d>:<passwor d>@www.<donai n>.com

This is at the user's discretion. Transaction security is not guaranteed.
7. Optional: Check Translate Created Labels,
8. Click OK.
Enabling Label translation

1. Select each Label control in the Screen Designer.
2. Check TranslateText in the property grid.

MultiLine

The MultiLine control is a text input field with multiple lines into which you type text which is inserted at a
specified screen location.

For example, MultiLine can be used to modernize or rationalize the layout of a screen with input fields that
contain more than one line. MultiLine controls can be placed where they are most useful. The information
you type into them is then inserted in the screen locations of the traditional editable areas.

When you type text in a MultiLine control, text wraps automatically. To insert a new line, press Alt+Enter.

When the control is used in a Plus session, the control displays the value from the screen location, at the
specified length. However, if the screen location is a protected field, no typing is allowed in the InputField

control.
Properties:
Name Default value Description
IsEnabled Checked Specifies whether the control allows user input.
IsNumeric Unchecked Specifies whether the input is numeric as opposed to all
characters.
Length 0 The maximum number of characters that the input field
can contain. A value of 0 means the number of characters
is limited by the length of the green screen field.

Note: The IsPassword property is not available for the MultiLine control. If password control is
required, you must use the InputField control.

MessageBox

The MessageBox control is an alert message box that can be configured with a title, icon, one to three
buttons, and a message.

MessageBox controls are particularly useful when a green screen produces a message, but the screen is
covered with a screen canvas. In this situation, the message cannot be seen. Using a MessageBox control
solves this problem.

Properties:
Name Default value Description
Title Title The title of the message box. Collector compliant.
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Name Default value Description

Text Message The message to be displayed in the message box.
Collector compliant.

Note: You can create a new line or split an
existing line by pressing Alt+Enter.

IconPath Warning.png Click the accelerator button to open the project image
pool folder where you can select an image file with a
format of JPG, GIF, or PNG. To select a different image,
click Add to pool and browse to the image you want to
use. The image file is then copied to the image pool and
saved with the project.

Four image files are supplied:

Error.png
Question.png
Warning.png
Information.png

Button
IsVisible Checked If checked, the button is displayed in the message box.
Unchecked
Checked
Caption OK The text to be displayed in the message box. Collector
Empty string compliant.
Cancel
Actions Empty list One or many actions to be executed sequentially from the
top to the bottom in the specified list in the Actions dialog
box.

RadioButton

The RadioButton control is used to add text at a specified screen location.

Note: When the control is used in a Plus session and, if the screen location is a protected field, the
control is disabled.

Properties:

Name Default value Description

GroupName Empty string The radio button group this radio button belongs to.

SelectedState Empty string The text to be used at the specified screen location and
any specified actions to be performed if the check box is
checked.

UnselectedState Empty string The text to be used at the specified screen location and
any specified actions to be performed if the control is not
selected.

Tab
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Tab provides an area of the screen to which you can assign other controls. You can have multiple Tab
controls on a screen, with multiple tab items within a Tab control.

To assign a control to a tab item, drag the control on to the appropriate tab item.
When you select another tab item, that tab item is shown, together with its controls.

i Notes:

» Deleting a tab item deletes all its assigned controls.
» Deleting a Tab control deletes all its tab items and their assigned controls.

Properties:

Name Default value Description

Tabltems Empty collection Lists all tab items and their controls. Each tab item has a
caption.

HeaderWidth Static Specifies the width of the tab item headers. Static sets a
fixed width specified by HeaderSize. Dynamic sets a
variable width according to the length of the header text.

HeaderSize 8 Specifies the fixed width of the tab item headers.

ColorSettings

Background Specifies the color used for the background of the control.
This can be one of:

e FromHost: The host background color is used.
* Custom: You select a color from the color palette.

Table

The Table control formats data from multiple screens as a scrollable table with filtering and sorting
capabilities.

The Table control uses a pre-defined GridCollector control as its data source. If there is already one, single
GridCollector on the screen, the Table control links to it automatically. If there is no GridCollector on the
screen, you must link to a GridCollector manually using the LinkedGridCollectorName property.

Properties:
Name Default value Description
LinkedGridCollect GridCollectorl Name of the GridCollector control to which the Table
orName control is linked.
Columns Collection of columns.
Title Name of the linked GridCollector The visible column title.
column.
IsVisible Checked When checked, the column is visible on a Plus
screen.
ColumnAlignment Left Aligns the cell text. Can be one of:
Left
Center
Right
ColumnAliasInGri Name of the GridCollector column from where the
dCollector data will be taken.
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Name Default value Description

ContentSettings

Data Type String Can be one of:
String
Number
Date
Control Type None The following controls are used to specify new values

in table cells. Can be one of:

None
TextBox
CheckBox
RadioButton
Calendar
Combo

For additional settings, click the accelerator key next
to the selected control.

Notes:

* TextBox specifies a standard text box. No
other settings are available.

* Combo works in a similar way to the
Chooser control.

IsHeaderVisible Unchecked When checked, the table shows the column headers.

IsFilterable Checked When checked, adds a Filter field to the table. The
typed value filters out all rows except those with
strings or a string prefix that match filter text in a

column.
IsMoreButtonVisi Checked When checked, adds a More button to the table title
ble bar. More pages down the screen until there is no
more table data.
IsAutoNavigateOn Checked When checked, the Table control triggers the
Load GridCollector to fetch the next pages automatically
when the Table control is activated.
IsExportButtonVis Unchecked When checked, adds an Export button to the table
ible title bar. This allows the user to export the table

contents to a comma-delimited . cSV file for use in
Microsoft Excel.

DefaultRowComm InPlace Used to specify an action or actions to be performed

and when the user double-clicks a row. When creating
actions, the following syntax can be used to take the
text from any table cell in a row that is double-clicked:

#H#ColumnAliasInGridCol lector##

The following syntax can also be used to take text
from any Collector control:

%%G lobalVariableName%%

If the value of DefaultRowCommand is set to one of
ClearField, SetCursor, or SetText, then
TextlnsertionLocation can be set to either:
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Name Default value Description

InPlace: The location of the control as specified in
the Screen Design view, or the location of the logical
marker defined by the SearchFor condition.

or:

Relative: The location of the action to be performed
relative to the location of the row that was clicked in
the linked GridCollector control, taking into account
the specified (row,column) Offset. See notes below.

Notes:

» If the value of TextinsertionLocation is Relative, forward or backward navigation might be
triggered on the green screen. If this happens, and the target row is no longer in the expected
location, the linked GridCollector control refreshes the data to resynchronize the table data with
the data collected from the green screen.

* The Offset (row,column) values are added to the left-most (row,column) location of the selected
record, as represented in the linked GridCollector control.

Modifying table data in Plus mode
To be able to modify table data, you need to add controls to the table using the Control Type settings.
To modify the data in Plus mode:

1. Use the table controls to change the data.
2. Click Save.

The table navigates to the pages containing the changed rows and updates the values on the green
screen. After the updates are complete, the GridCollector SaveCommand action runs. This saves the
changes to the green screen application.

Tooltip
The Tooltip control is activated when the mouse pointer hovers over the screen area that Tooltip occupies.
There are two modes for Tooltip:

Static mode Where the content of Tooltip is a free string. The string can include global parameters
set by Collectors.

Advanced mode Where Tooltip can read text from a screen location and use it as the displayed text.

Properties:
Name Default value Description
Caption Empty string Specifies the text displayed by Tooltip. Data stored by
Collector controls can be used.
Advanced Unchecked When checked, activates advanced mode.
KeyTextLocation InPlace The (row,column) where the text should be taken from the

screen. InPlace means the location of the control as
specified in the Screen Design view, or the location of
the logical marker defined by the SearchFor condition.

The screen location can also be defined by using the
Select Screen Location window, opened by clicking the
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Name Default value Description

accelerator button next to the KeyTextLocation field.
Advanced mode only.

Tooltipltems Specifies a list of items the Tooltip control displays.
Advanced mode only.

Key: The string on the host screen under which the
tooltip caption will be displayed.

Caption: The text that will be displayed on the Tooltip
control. Data stored by Collector controls can also be
used. Press Alt+Enter to add a new line.

Importing items from a . csv file
To use this feature successfully, the contents of the . csv file must be in the following format:
<KEY><DEL><TI P>

where:

This ... Denotes this ...
<KEY> Key representing on-screen emulation text.
<DEL> Delimiter (;). This is the only supported delimiter.
<TI P> Tooltip text.

For example:

#Tool Tip values

TSO;TSO log on

Password;Enter your password

Application required;Enter your CICS application name
Userid;Enter your user 1D

To import a -csV file:

1. Click the accelerator button next to Tooltipltems in the property grid.
2. In the Tooltipltems dialog box, click the Import icon.

3. Select the .csv file.

4. Click OK.

WebFrame

WebFrame is a control, which can be displayed either as an icon or as an embedded window on the
screen. An icon looking like a small globe can be set to open a map based on the postal address displayed
in the host screen field. An embedded window displays content at a specified Web address when the
screen arrives.

Properties:
Name Default value Description
Mode Popup Specifies whether WebFrame is displayed as an icon
(Popup) or as an embedded window (Embedded).
ImagePath Empty string Click the accelerator button to open the project image
pool folder where you can select an image file with a
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Name

Default value

Description

URLSource

Width
Height

Empty string

500
500

format of JPG, GIF, or PNG. To select a different image,
click Add to pool and browse to the image you want to
use. The image file is then copied to the image pool and
saved with the project.

Alternatively, you can type the location of an image in the
form of its full path or full Web address in the ImagePath
field.

Only available if Mode is Popup.

Any valid Web address. The data stored by Collector
controls can be used to specify the target.

Window width in pixels.

Window height in pixels.

Shared properties

Each of the following properties may be used by more than one type of control:

Name

Default value

Description

Name

Caption

IsVisible

Tooltip

TextInsertionLocation

BoundVariable

ControlTarget
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Name of the control

Checked
Empty string

InPlace

MainArea

Specifies a custom name for the control.

Note: If a rule creates more than one control of
the same type on the same screen, the following
naming convention is used:

<name>, <nane>_1, ...
<nanme>_<nane>

The text to be displayed on the control. You can make the
text bold, italic, or underlined in the Style section of the
property grid.

When checked, the control is visible on a Plus screen.

The tool tip text is displayed when the mouse pointer
hovers over the button. If empty, no tool tip is displayed.

The (row,column) where the text is inserted on the
screen.

* InPlace means the location of the control as specified
in the Screen Design view, or the location of the
logical marker defined by the SearchFor condition.

* None means that the control has no specified location
on the green screen and that its function is
independent of the green screen.

The screen location can also be defined by using the
Select Screen Location window, opened by clicking the
accelerator button next to the TextInsertionLocation
field.

A data source that controls can use to read from or to
write to so that they can interact with each other.

The control target is the region specified in the currently
selected theme, where the control is placed. MainArea is
the region occupied by the green screen.




Name Default value Description

Style Empty string Style defines the look of a control. Its possible values are
displayed in the list of items taken from the currently
selected theme. If not specified, the default style is used.

ColorSettings

Background Specifies the color used for the background of the control.
This can be one of:

¢ FromsStyle: The color is taken from the color defined
in the theme style.

* FromHost: The host background color is used.

* Custom: You select a color from the color palette.

Foreground The color used for the foreground of the control. This can
be one of:

e FromsStyle: The color is taken from the color defined
in the theme style.

¢ FromHost: The host foreground color is used.

¢ Custom: You select a color from the color palette.

FontSettings Specifies the font of the text used:

« Bold, Italic, and Underline for CheckBox, Label,
RadioButton, and Tooltip.

¢ Bold and Italic for Button.

RowOffset 0 Vertical offset relative to the row where the logical marker
is located. Logical markers are defined by the SearchFor
condition. A positive or negative value defines the screen
location as the number of rows down or up the logical
marker.

A wrong offset value can adversely displace the control.

ColumnOffset 0 Horizontal offset relative to the column where the logical
marker is located. Logical markers are defined by the
SearchFor condition. A positive or negative value defines
the screen location as the number of columns from the
right or left of the logical marker.

A wrong offset value can adversely displace the control.

RowSpan 0 If not zero, overrides the height of a logical marker
defined by the SearchFor condition.
ColumnSpan 0 If not zero, overrides the width of a logical marker defined
by the SearchFor condition.
ZOrder The highest ZOrder value  Specifies the stacking order of a two or more controls.
of all controls on the current Controls with higher ZOrder values appear further up the
screen on the Screen stack or closer to the foreground.
Design page except
Topmost + 1
TabOrder Default (order by location)  Specifies the navigation order of the cursor when using

the Tab key. The tab order is displayed by selecting the
TabOrder icon on the Screen Designer toolbar. Only a
customized tab order is displayed, not the default order.
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Actions

Actions are executed in the order in which they are added in the Actions dialog box.

EmulationCommand

RunApplication

RunMacro

RunScript

SetCursor
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specified address.
Runs a specified emulation
command.

Run a specified application
on the user's machine.

Runs a specified macro.

Runs a specified script.

Places the cursor at the
specified screen location.

Action Description Values
ClearField Clea_rs_ the_ contents of a FieldLocation The (row,column) where the field is
specified field at s specified
. located on the screen. InPlace means
screen location. . o
the location of the control as specified
on the Screen Design page, or the
location of the logical marker defined
by the SearchFor condition.
The screen location can also be
defined by using the Select Screen
Location window, opened by clicking
the accelerator button next to the
FieldLocation field.
Email Sends an email to a

ActionTarget The recipient’s email address.

EmulationCommand Possible values are shown in a
list.

ActionTarget
Command line to run. For example:

C:\Program Files (x86)\Skype\Phone
\Skype.exe

AdditionalArguments

Application arguments. For example:
/callto:+555555

Data stored by Collector controls can be used to specify
parameters for ActionTarget and AdditionalArguments.

ActionTarget Full path to the macro file to run, or the
path relative to the macros folder. Data
stored by Collector controls can be
used to specify arguments.

ActionTarget Full path to the script file to run, or the
path relative to the scripts folder. Data
stored by Collector controls can be
used to specify arguments.

CursorLocation The (row,column) where the cursor
should be placed on the screen.
InPlace means the location of the
control as specified in the Screen
Design view, or the location of the
logical marker defined by the
SearchFor condition.




Action

Description

Values

SetText

SetValueToAVariable

WebSite

Inserts text into the
specified screen location of
an unprotected field.

If the specified location is
not in any unprotected field,
no action is performed.

Creates a global variable
and sets its value. If the
global variable already
exists, its value is reset.

Runs the user’s default
browser to navigate to a
specified Web site.

The screen location can also be
defined by using the Select Screen
Location window, opened by
clicking the accelerator button next
to the CursorLocation field.

TextlnsertionLocation The (row,column) where the

ActionTarget

GlobalVariableName

Content

control is inserted on the
screen. InPlace means the
location of the control as
specified in the Screen
Design view, or the location
of the logical marker defined
by the SearchFor condition.

The screen location can also
be defined by using the
Select Screen Location
window, opened by clicking
the accelerator button next to
the TextInsertionLocation
field.

The text to be inserted.

The name of the global variable.
The value of the global variable.

Expressions containing values of
other already existing global
variables may be used in the
form %

%<ot her vari abl e_nanme>
%%.

ActionTarget Web site address. Data stored by
Collector controls can be used to
specify arguments.

The control context menu

When you right-click a control, a context menu appears with the following menu options:

Option

Description

Convert to Rule

Cut

Copy
Paste

Delete

Disable / Enable

Converts a static control in the Screen Design view to a dynamic control managed by

the Rule Manager.

Cuts a control to the Screen Designer clipboard.

Copies a control to the Screen Designer clipboard.

Pastes a control from the Screen Designer clipboard to the screen that is currently
displayed in the working area of the Screen Design view.

Deletes a control.

Disables a control so that it remains in your project, but is not used in the customized
screen. An exclamation mark appears at the top right of the control to show that it is
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Option

Description

Send to Back

Bring to Front

disabled. To enable a control, right-click the control and select Enable from the pop-up
menu.

You can still edit disabled controls but they will not be used on a customized screen
until you enable them.

If you copy a disabled control or convert it to a rule, the control remains disabled.

If two or more controls appear over each other, this option sends the selected control to
the back of the stack of controls.

If two or more controls appear over each other, this option brings the selected control to
the top of the stack of controls.
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How To

This section contains additional information about the Screen Designer, controls, and rules.

Use themes

A theme defines the layout of the screen and the look of each control across all screens in a customization
project.

The screen layout is defined as having a rectangular main area in the center, which can be surrounded by
rectangular areas (margins). Margins are defined by the theme you use.

The main area of a screen can contain any type of control. However, margins can contain only buttons or
images.

Note: To add buttons to the margins of a theme, drag the control icon from the property grid in the
Screen Design view. To add images to the margins of a theme, use the Theme Editor.

In the example below, two images have been added to the project theme using the Theme Editor. The two
buttons in the left margin have been added from the property grid in the Screen Design view:

T —— ! i

4 My corporate logo o

/1, Important: If you change a theme, the margins of the previous theme disappear, together with their
*~ contents. It is therefore best to choose a theme early in the customization project.

Some themes are included with the Screen Designer. Additionally, you can use the Theme Editor to design
your own theme.

Selecting a theme

1. Select Tools > Project Settings

The Project Settings dialog box appears.
2. Click Themes in the left pane.
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Click Change in the right pane. The Choose Theme dialog box appears.
Select the thumbnail of the theme you want to use from the left pane.
Click OK.

Click OK in the Project Settings dialog box.

The theme is applied to all the screens in your project.

Creating a Windows theme

1.

Select Tools > Theme Editor.

The Theme Editor window appears.
Select File > New.

The Create Theme dialog box appears.
Type an appropriate name for the theme in the Theme Name field.
Click OK.

The Theme Editor design screen appears.
Select a design from the Layouts pane.

The layout appears in the center pane.
In the Skins pane, select BaseWindowsSkin from the drop-down list.

i Note: If you select a Windows theme, you cannot edit the skin of a control.

In the center pane, select a color from the Theme Preview Background list to display a background
color for the theme.

Note: This only displays a preview of the color. To use a specific color, you must change the
background color in your emulator display.

To add a background or image to a pane of the theme, select the pane, then select the color or image
from the Background or Image list, as appropriate’.

When you have finished, select File > Close.

The design screen closes.

10.In the Theme Editor window, select File > Exit.

Creating a green screen theme

1.
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Select Tools > Theme Editor.

The Theme Editor window appears.
Select File > New.

The Create Theme dialog box appears.
Type an appropriate name for the them in the Theme Name field.
Click OK.

The Theme Editor design screen appears.
Select a design from the Layouts pane.

The layout appears in the center pane.
In the Skins pane, select BaseGreenScreenSkin from the drop-down list.
Optional: Select a color from the Base color drop-down list.

This determines the base foreground color used in the theme.



8. In the center pane, select a color from the Theme Preview Background list to display a background
color for the theme.

Note: This only displays a preview of the color. To use a specific color, you must change the
background color in your emulator display.

9. To add a background or image to a pane of the theme, select the pane, then select the color or image
from the Background or Image list, as appropriate’.

10.When you have finished, select File > Close.

The design screen closes.
11.In the Theme Editor window, select File > Exit.

Search history screens

You can search the thumbnail screens in the history pane for text strings that appear either on a screen or
as part of a screen ID.

At the bottom of the history pane, type a search string in the search field. The thumbnails are filtered,
leaving only those screens that contain the search string.

Create modern screens with a screen canvas

Modern screens often require more space than the fixed green screen layout. You can free yourself from
the fixed screen defined by the terminal. To do this, you define settings for a screen canvas, then add
controls in the same way you would on a green screen.

As well as customized screen sizes, the screen canvas feature supports the following screen types:

* Model 2 (24x80)
* Model 3 (32x80)
* Model 5 (27x132)

Another advantage of using a screen canvas is being able to place a larger canvas over a smaller green
screen to maximize the space on the screen.

Defining default canvas settings

To define default settings for screen canvas, use the Project Settings dialog.

y Note: You can specify different settings for selected screen by selecting Tools > Screen Canvas.

1. Select Tools > Project Settings.

The Project Settings dialog box appears.
2. Click Screen Canvas in the left pane.

The screen canvas settings appear in the right pane.
3. Specify the settings you want:

Setting Description

Canvas Size Note: The canvas size cannot be smaller than the size of the selected
green screen.

Number of Rows Specifies the number of rows for the new screen. Default is the number of
rows on the green screen.
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Setting

Description

Number of Columns

Canvas Font Size
Fixed Font Size
Canvas Background
Color

Image

Image Layout

Apply settings automatically to
each new history screen

Specifies the number of columns for the new screen. Default is the number of
columns on the green screen.

Defines the font size. Default is 26 pt.

When checked, the font size does not change if the window is resized.

Defines the background color. Default is white. Can be used with Image.

Click the accelerator button to open the Choose Image dialog box to select
an image for the background. Can be used with Color.

Select one of:

Stretch
Fill

Fit

Tile
Center

When checked, a screen canvas with the defined default settings is applied
automatically to each newly-imported history screen.

Note: This setting hides all green screen fields. We therefore
recommend using Auto-Generate Controls when you use this
setting.

Defining settings for a selected screen

1. Select a screen from the history pane.
2. Select Tools > Screen Canvas.

The Screen Canvas dialog box appears.

Note: You can also right-click the screen in the work area and select Screen Canvas > Settings

from the pop-up menu.

3. Specify the settings you want:

Setting

Description

Canvas Size

Number of Rows

Number of Columns

Canvas Font Size
Fixed Font Size
Canvas Background
Color

Image

Image Layout

Note: The canvas size cannot be smaller than the size of the selected
green screen.

Specifies the number of rows for the new screen. Default is the number of
rows on the green screen.

Specifies the number of columns for the new screen. Default is the number of
columns on the green screen.

Defines the font size. Default is 26 pt.

When checked, the font size does not change if the window is resized.

Defines the background color. Default is white. Can be used with Image.

Click the accelerator button to open the Choose Image dialog box to select
an image for the background. Can be used with Color.

Select one of:

Stretch




Setting Description
Fill
Fit
Tile
Center
4. Click OK.
Note: To override the default screen canvas settings with the settings you have just defined, click Set
As Default.

Copying and pasting a screen canvas

If a screen already has a screen canvas applied to it, you can copy the canvas and its settings, then apply
it to another screen. To do this:

1. Select a screen from the history pane.

2. Right-click the screen in the work area and select Copy Canvas from the pop-up menu.

3. Select another screen from the history pane.

4. Right-click the screen in the work area and select Paste Canvas from the pop-up menu.

The copied screen canvas and its settings are applied to the screen.

Removing a screen canvas

To remove a screen canvas from a green screen, right-click the screen in the work area, then select
Remove Canvas from the pop-up menu. Any controls that you added to your Plus project are not affected.

Example

In the Adding controls section, we added controls to screens from the Demo Host to provide a modern look
and feel. This example shows you can modernize screens even more.

Using a screen canvas, we can give the welcome screen a clean, crisp modern look:
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Note the use of the Theme Editor to add a top banner and logo.

Selecting the host system takes you to the same screen as before, but with a fresher look:
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Note the use of auto-generated controls to completely replace the original green screen.

|Identify screens
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About screen identification

The Screen Designer supports the following ways of identifying screens:

Default An identification that is calculated from a screen's field data. Used by default.

To customize screens, a screen ID must be assigned to each screen. Unfortunately, this
default screen ID might not be sufficient. This occurs when several screens, which have to
be distinguished, get the same screen ID. It can also occur when several screens, which
have to be addressed as the same, get different screen IDs.

Selection  An identification based on the contents of one or more screen selections. When the default
based screen ID is not sufficient, you can select the contents of a screen location to act as the

screen ID. If you make more than one selection, the contents of each selection are joined
together to form the screen ID. Each selection is limited to the height of one row on the
screen.

Note: Before you start to customize the screens in your project, you must choose either the default
screen ID type or a selection based screen ID type. You cannot change the screen ID type once you
have started to customize a screen.

Custom screen For each screen recorded during your session you can define a custom identification
identification algorithm. For custom screen identification, you define a set of selected areas on a

screen and specify a name for them. This defines screen data to distinguish a
particular screen from other screens in your project. The custom identification name is
assigned as a screen ID to each screen of your project that has exactly the same data
in exactly the same selected areas as your custom identification.

You can choose either selection based selection screen identification, custom screen identification, or a
combination of both. In this way, you can either distinguish between screens which otherwise would have
had the same ID, or identify similar screens which otherwise would have had different IDs.

Specifying selection based screen identification

1.

6.
7.

Select Tools > Project Settings.

The Project Settings window appears.
On the Screen ID page, click Select next to Selection Based.

The Selection window appears.

Select a screen thumbnail in the left pane.

In the work area, select a portion of text on the screen by drawing a rectangular border within a single
screen row with the mouse.

The selected text is added as an ID to any screen in your project that has the same text in the same
location.

Optional: You can also add other screen selections to form the screen ID. The text in each selected
screen location is joined together to form the screen ID.

Click OK.
Click OK in the Project Settings window.

Removing a selection:

To remove a selection, right-click the selection and select Remove This Selection from the pop-up menu.
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Specifying custom screen identification

1. Select Tools > Project Settings.

The Project Settings window appears.
2. Onthe Screen ID page, click Manage Screen Identification.

The Manage Screen Identification window appears.

3. Select a thumbnail from the left pane.

4. Click Add Custom Identification in the right pane.

5. Select text areas on the screen by drawing rectangular borders within single screen rows with the
mouse.
The history pane on the left is filtered to show only those screens that have the same text areas at the
same locations that you selected.

6. Type a nhame in the Name field.

7. Optional: Check Use With Base ID. The base ID results from the screen ID type you chose before you
started customizing screens. When this option is checked, the base ID is used as an additional form of
screen identification.

The name you specified is used as a custom screen ID of any screen in your project that:

« Has the same text areas at the same locations that you selected.
* Has the same base ID (if Use With Base ID is checked).

Note: The base ID is displayed on the top of each thumbnail in the left pane, while the screen ID is
displayed on the bottom of each thumbnail.
8. Click OK.

f Note: Make only one custom identification a the screen before you click OK.

9. Click OK in the Project Settings window.

Removing custom screen identification:

To remove a selection, right-click the selection and select Remove This Selection from the pop-up menu.

i Notes:

* You cannot define the same custom screen ID for two different screens if either one or both of
them are customized.

» A screen cannot have more than one custom screen ID. You cannot specify a custom screen ID if
the screen already has one.

« A screen ID ambiguity will be caused if you try to import an additional project where at least one
screen fits a custom ID of the base project but that screen already has a custom screen ID. The
affected screen will be marked as having a screen ID ambiguity in the Screen Design view.

» You cannot import an additional project that has a screen with screen ID ambiguity. The project
must be reviewed first to fix the problem.

Manage controls

Auto-generating controls

In some cases, you might want to recreate the full screen. You can do this by generating Label and
InputField controls automatically for all protected and unprotected fields on a green screen. To do this:
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Select Tools > Project Settings.

The Project Settings dialog box appears.
Click Auto-Generate Controls in the left pane.
Specify the settings you want:

Check this ... To do this ...

Generate Labels When checked, Label controls are created for each
protected field on the screen.

Exclude Labels created from empty fields When checked, filters out Label controls that are
created from protected fields that contain no text. Only
available if Generate Labels is checked.

Generate Input Fields When checked, Input controls are created for each
unprotected field on the screen.

Auto-generate controls on all new history screens ~ When checked, Label and InputField controls are
automatically generated on all newly-imported history
screens. Unchecked by default.

4. Click OK.
5. To auto-generate the controls on the current screen, select Tools > Auto-Generate Controls.

Changing the opacity level

You can use the slider on the toolbar to change the opacity of all controls on a screen from full opacity to
20% opacity.

Clicking the Opacity level icon displays the opacity slider and toggles the set opacity on and off.

Selecting multiple controls

You can select more than one control at any time so you can perform the same action once on the selected
controls, instead of once for each control.

You can select controls in one of the following ways:

Use your mouse to draw an area of the screen containing the controls you want to select.
Press Ctrl+A to select all controls on the screen.

Right-click the screen background and select Select All.

Use Ctrl+Click to toggle whether a screen is selected.

You can perform the following actions on the selected controls:

Move (using the mouse or arrow keys)
Delete

Cut

Copy

Paste

Duplicate

f Note: You cannot select Rule Manager controls as part of a multiple selection.

Working with rule controls

Rule controls are controls created using the Rule Manager.
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About rule controls

When you create rule controls, they also appear in the Screen Design view. By default, this feature is
turned on. You can toggle between showing and hiding rule controls by selecting View > Rule Controls.

Rule controls are designed to be used on multiple screens. They are therefore shown in the Screen
Design view in a different style to single-screen controls so you can easily differentiate between them.

You can edit rule controls in the Screen Design view in the same way as in the Rule Manager. However,
you cannot resize, move, delete, copy, or duplicate these controls, as shown by a small padlock in the top
right corner of the control.

Editing rule controls

In the same way as a single-screen control, you can edit the control's properties using the property grid.

1. To edit a rule control in the Screen Design view, right-click the control and select Edit Rule from the
pop-up menu.

The rule opens in the Rule Wizard.

f Note: When you edit one rule control, it affects all the controls created by the source rule.

2. To view a rule control, right-click the control and select Show Rule from the pop-up menu.

The rule opens in the Rule Manager window.

Modify table data in Plus mode

You can modify table data in Plus mode by using controls you have previously configured in the Screen
Designer.

This example shows you how to add a combo list box to each row of a table.

Configuring table controls in the Screen Designer

Open the DemoHost project you created earlier.

Navigate to the EUROPEAN CUSTOMER LIST screen.

Select the table.

In the property grid, click the accelerator button next to Columns.

P w bR

The Columns dialog box appears.
In the Column Items frame, select 5 - Column - Country.
6. In the Properties frame, select Combo from the Control Type list:

o
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7. Click the accelerator button next to the list.

The Combo Control Settings dialog box appears:

Eantrol Settings s !
{Collection]

[sEdtable

8. Click the accelerator button on the Entries.

The Entries dialog box appears.
9. Click the Add button to create a combo item.
10.In the Properties frame, type Belgium in the Entry field:

Combo Hems Properties:
[ Entey - Belgium 4  Combotonirolitem |
4 Common
' -
4
X
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11.Create more combo items for:

Britain
France
Germany
Italy
12.When you have finished, click OK.
13.Click OK in the Combo Control Settings dialog box.
14.Click OK in the Columns dialog box.
15.Save the project and create the Plus archive.

Using Table controls in Plus mode

1. Connect to the Demo Host and start Plus mode.
2. Associate the Plus archive you have just created with the host session.
3. Navigate to the EUROPEAN CUSTOMER LIST screen.

The Country column now contains a combo list on each row.
4. On the first row, select Italy from the list:

:

Reflection Workspace - [Demo Hostod3a]

ey -

: [
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Conmecied to the host [demoiplus32sim| HUM vispm | B @ -

5. Click Save at the bottom of the table.

Execute a Table action relative to a row position

In some host tables, selecting a row can require action in a field that is in a relative position to that row. For
example, there might be an input field next to every row in a table, and selecting a row might require a
particular action to be executed in that relative field.

The following Table control actions can be performed, relative a to row position:

SetText

92 | How To



SetCursor
ClearField

The figure below shows a GridCollector control in the Screen Designer. The arrow points to the location of
the left-most column of the selected row. The relative location is calculated as an offset from that point, with

the left-most column represented as (0,0):

% ASADD Display - Micra Focus Rumés

Fie Edit View Connection Transfer Options Tooh Rumbe+ Help

-BTOH®R - W MHE nk P He,

& [l #s400 Dinpiey b

Comnected oMW B1D05544 QPADEVDDGS 272 kel 1310402

In this example, the position to execute the action is in the Option column on the same row. This is five
screen cells to the left of the start of the selected row. The row offset is therefore 0 and the column offset is

-5.
To configure the table:

1. Inthe Screen Designer, add a GridCollector to a table:
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Place a Table control over the GridCollector control.

In the property grid, uncheck IsMoreButtonVisible.
Uncheck IsAutoNavigateOnLoad.

Check IsExportButtonVisible.

Click the accelerator button next to DefaultRowCommand.

oo s ®wN

The DefaultRowCommand dialog box appears.
7. Select SetText from the Select type list.
8. Click Add.
9. In the Properties frame, type X in the Text field.
10.Select Relative from the TextinsertionLocation list.
11.In the Offset frame, leave Row at 0 and set Column to -5:
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12.Click OK.
13.Save the project and create the Plus archive.
14.In Plus mode, when you double-click a table row, a X appears in the Option column:
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Adding ClearField actions:

If you only want to have a X on one selected row at a time, you can add a ClearField action for each row of

the table:
ekt type Properies
bl Clearfieid
4 Aertion
+ =
4 “InarFak

oK Cancel

When you double-click a row, a X appears on that row and is removed from any previously selected row.

Use controls to set a variable

You can use the contents of an input control, such as an InputField control, to set a variable which can be
used, at any time and in any place, by the action of another control. To do this, you use the BoundVariable

action of the input control.

The following input controls use bound variables:
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* Calendar

¢ CheckBox
* Chooser
e InputField

+ RadioButton

Use Web components in Plus

How To

Plus can call both applications and Web components using one or more of the following controls:
Button A labeled Ul control. It can call an application, script, URL, or Web page.

WebFrame Creates an icon using an image. You can set the size of the frame. Only valid for Web
browser URLs. No address bar is displayed.

Passing parameters to an application or Web page

You pass parameters to an application or Web page using the Collector control. Place a Collector control
over the data fields that Plus uses to capture data. When the application runs, there is nothing to show on

the screen that indicates this is a data collection field.

You add Collector controls in the Screen Design view:

L - —— = |

i Note: Collector controls should cover the entire data field to accommodate long strings.

When you configure a Collector control, you give it a name in the property grid. This name must be unique
in the Plus archive. You can refer to the data stored in the database as %%Name%%. In the figure above, the

Name of the first collector is MapCity and its global variable name is %%MapCi ty%%.

The TrimSpaces property resizes the length of the data string by removing trailing spaces. In most
applications, this option should be 1.

Creating Web objects and URLSs

The first thing to do is to create a working URL using a known set of parameters for a known address. For
example, this Google Maps parameter is for an Office Park in Maryland:



http://maps.google.com/maps?g=700 King Farm,Rockville, MD

Copy the working URL to an editor such as Notepad so you can edit it for use in the Screen Designer. For
example, the following string re-creates the address string:

%%MapAddri% , %WhMapC i ty%% , %%MapState®%
Note that the commas (,) used as delimiters in the Google command, are still in place in the Plus string.

Add a WebFrame control to receive the data from the Chooser control:

| 1 Eamchinst - Mase fanus Soresn Coetigrar = S |

The command to copy and paste into the WebFrame URLSource field is:
http://maps.google.com/maps?g=%%MapAddri%, %%MapC i ty%%, h%MapStatel

In Plus mode, the Collector control captures the information you type. When clicked, the WebFrame control
takes that data and shows the location of the address on a map in a remote window.

As the character strings get more complex, testing becomes more important. For example, the following
string calls a Google charting facility for a pie chart. Notice that the original URL contains a section that
deals with both chart labels (AREA-A, etc) and chart data (T=:100,300,200,50). Other editable data
includes colors, format, and sizing:

http://chart.googleapis.com/chart?chs=300x150&cht=p3&chco=0000FF | OOFFOQO0|
FFO00O0 | FFFF00&chds=0,1000&chd=t:100,300,200,50&chdI=AREA-A] AREA-B| AREA-C | AREA-
D&chtt=TOYS

As in the Google Maps example, we need to replace the data portion of this URL with variables collected
from the Plus screen. In this case, the data portion (specified by chd), becomes:

chd=t: %%R1Jtoy%% , %%R2Jtoy%% , %%R3JItoy%% , %%R4Itoy%%
The new URL to use with the WebFrame control becomes:

http://chart.googleapis.com/chart?chs=300x150&cht=p3&chco=0000FF | OOFFOO]
FFO0O0O0 | FFFF00&chds=0, 1000&chd=t : %%R1Jtoy%% , %%R2Jtoy%% , %%R3JItoy%% , %%R4JItoy%
%&chdl=Regionl]Region2|Region3|Region4&chtt=TOYS

In a real application, you might also want to modify the label data dynamically as well. A label section might
therefore look like this:

chdl=%%Labe 1 1%% | %%Labe 12%% | %%Labe 1 3%% | %%Labe 14%%

You can experiment with the Google pie chart URL using the TOYS screen on the Demo Host.
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Import additional projects

You can import additional customization projects to merge with a project that is currently open in the
Screen Designer.

To do this, select File > Import Project.

f Notes:

« You cannot import a project if the base project is not open.
* The project name and theme will be the same as the currently open project.

The table below provides information about some circumstances where not all data might be included in an

import.

If this happens ... Then this happens ...

The screen ID configuration of the other project is Following the import attempt, the operation halts with an
different from the one defined in the base project. error message.

You import a project in which custom screen IDs are If all the custom screen IDs are valid, they are added to
defined. the custom screen IDs list of the base project.

You import a project in which custom screen IDs are The custom screen ID is added to the project with a new

defined. However, one of the custom screen ID names name: Origcustom screen ID - Copy,

already exists in the base project, although the custom Origcustom screen ID - Copy (2).Any

screen IDs are not identical. references to the renamed custom screen ID are
changed accordingly.

You import a project with a rule which is identical to one  Duplicated rules appear only once.
of the rules in the base project.

You import a project in which custom screen IDs are Not all of the new custom screen ID’s related rules are

defined. One of the custom screen IDs is not valid merged into the project. Information is shown in the

because it is assigned to a screen that has another results dialog box.

custom screen ID.

You import a project that includes a local resource. If the name of the resource already exists, you can select
one of:

« Copy and Replace
« Don’t Copy
+ Copy, but keep both files

You can also import additional customization projects using the Screen Designer command line. See Use
the Screen Designer command line.

Use the Screen Designer command line

You can use the Screen Designer command line to:

» Create one or more Plus archive files from Screen Designer project files.
« Import multiple projects to a current Screen Designer project.

Syntax

<I'nstal | _Di r>\Plus\ScreenDesigner\RumbaScreenDesignerCLI .exe [/P
<project file path> | /L <project file_ list_path>] [/0 <output dir>][/S] | 71
<config file> | /7

where:
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<Install _Dir> is the folder where the Screen Designer is installed.
/P <project _file_path> is the fully qualified path to a single project file.
/'L <project_file_list_path> isthe fully qualified path to a file that contains a list of project files.

Each path and file name must be on a separate line. You can use
the pound sign (#) to comment out a line.

/'O <output _dir> is the fully qualified path of where to export the Plus archives.
Optional. If not specified, the <l nst al | _Di r >\Plus
\ScreenDesigner folder is used.

/'S saves the project after the Plus archive is created.
/1 <config file> is the fully qualified path of the configured list of projects to import.
/? shows this information on the screen.

Generating customization files

Syntax

<Instal |l _Di r>\Plus\ScreenDesigner\RumbaScreenDesignherCLI .exe [/P
<project file path> | /L <project file_list_path>] [/0 <output _dir>][/S]

Example: Generating a single Plus archive

RumbaScreenDesignerCLI.exe /P C:\Users\<user nanme>\My Documents\Micro Focus
\Reflection\Plus\Projects\TableTest\TableTest.rsdp /0 C:\Users\<user _nane>\My
Documents\Micro Focus\Reflection\Plus\Rules /S

Example: Generating multiple Plus archives

RumbaScreenDesignerCLI.exe /L C:\Screen Designer\Projects\ProjectList.txt /0
C:\Users\<user _nane>\My Documents\Micro Focus\Reflection\Plus\Rules /S

Example project file list contents:

C:\Users\<user _nane>\My Documents\Micro Focus\Reflection\Plus\Projects

\ul\ul.rsdp
#C:\Users\<user _nane>\My Documents\Micro Focus\Reflection\Plus\Projects\unique

\unique.rsdp

C:\Users\<user _nane>\My Documents\Micro Focus\Reflection\Plus\Projects
\TableTest\TableTest.rsdp

C:\Users\<user _nane>\My Documents\Micro Focus\Reflection\Plus\Projects
\longtable3\longtable3.rsdp
C:\work\mobile\TestApplications\TestPlanAppCSIMVS\TestAppCSIMVS
\TestAppCSIMVS.rsdp

f Note: You can use the pound sign (#) to comment out a line.

Importing project files

Syntax
<I'nstal | _Di r>\Plus\ScreenDesigner\RumbaScreenDesignerCLI .exe /1 <config_file>
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<Instal |l _Dir>\Plus\ScreenDesigner\RumbaScreenDesignerCLI.exe /1 C:\Screen
Designer\Projects\ImportFileList.txt

Example project file list contents:

duplicateresource=ckb

baseproject=C:\Users\<user nanme>\My Documents\Micro Focus\Reflection\Plus
\Projects\MergeProjectsl\MergeProjectsl.rsdp

project=C:\Users\<user _nanme>\My Documents\Micro Focus\Reflection\Plus\Projects
\MergeProjects2\MergeProjects2.rsdp

project=C:\Users\<user nane>\My Documents\Micro Focus\Reflection\Plus\Projects
\MergeProjects3.rsdp

project=C:\Users\<user nane>\My Documents\Micro Focus\Reflection\Plus\Projects
\MergeProjects2\MergeProjects2.rsdp

project=C:\Users\<user _nanme>\My Documents\Micro Focus\Reflection\Plus\Projects
\al\al.rsdp

project=C:\Users\<user nane>\My Documents\Micro Focus\Reflection\Plus\Projects
\WYSIWYG\WYSIWYG\WYSIWYG. rsdp

saveto=C:\Users\<user nanme>\My Documents\Micro Focus\Reflection\Plus\Projects
\MergeProjects20

where:

duplicateresource specifies copy options for duplicate resources:

cr Copy and replace.
dc Do not copy.
ckb Copy, but keep both files.
baseproject is the base project that the projects will be imported to.
project is the absolute or relative path to the project file.
saveto is the path of the resulting merged project. If not specified, the base project is used.

If the project does not exist, a new project is created at that location with a name
matching the folder name. For example, if the path is:

C:\Users\<user_name>\My Documents\Micro Focus\Reflection\Plus
\Projects\MergeProjects20

the created project is called MergeProjects20.
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Contacting Micro Focus

Our Web site gives up-to-date details of contact numbers and addresses.

Further information and product support

Additional technical information or advice is available from several sources.
The product support pages contain a considerable amount of additional information, such as:

* The Product Updates section of the Micro Focus Customer Care Web site, where you can download
fixes and documentation updates.

* The Examples and Utilities section of the Micro Focus Customer Care Web site, including demos and
additional product documentation.

« The Support Resources section of the Micro Focus Customer Care Web site, that includes
troubleshooting guides and information about how to raise an incident.

To connect, enter https://www.microfocus.com/en-us/support in your browser.

y Note: Some information may be available only to customers who have maintenance agreements.

If you obtained this product directly from Micro Focus, contact us as described on the Micro Focus Web
site, www.microfocus.com. If you obtained the product from another source, such as an authorized
distributor, contact them for help first. If they are unable to help, contact us.

Also, visit:

« The Micro Focus Community Web site, where you can browse the Knowledge Base, read articles and
blogs, find demonstration programs and examples, and discuss this product with other users and Micro
Focus specialists.

« The Micro Focus YouTube channel for videos related to your product. .

Information we need

However you contact us, please try to include the information below, if you have it. The more information
you can give, the better Micro Focus Customer Support can help you. But if you don't know all the answers,
or you think some are irrelevant to your problem, please give whatever information you have.

* The name and version number of all products that you think might be causing a problem.

e Your computer make and model.

* Your operating system version number and details of any networking software you are using.
e The amount of memory in your computer.

* The relevant page reference or section in the documentation.

* Your serial number. To find out this number, look in the subject line and body of your Electronic Product
Delivery Notice email that you received from Micro Focus.

Contact information

Our Web site gives up-to-date details of contact numbers and addresses.

Additional technical information or advice is available from several sources.
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The product support pages contain considerable additional information, including the Product Updates
section of the Micro Focus Customer Care Web site, where you can download fixes and documentation
updates. Go to Micro Focus Product Updates.

To connect, enter https://www.microfocus.com/en-us/home/ in your browser to go to the Micro Focus home
page, then click Support & Services > Support. Type or select the product you require from the product
selection dropdown, and then click Support Login.

If you are a Micro Focus Customer Care customer, please see the Welcome to Customer Care document
that includes information about downloading and licensing your product, contacting Customer Care, and
about reporting an incident. You can download it from our Web site. Support from Micro Focus may be
available only to customers who have maintenance agreements.
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